[eMule-Web]

[eMule-Web] (http://www.emule-web.de/board/)
-   Xtreme MOD (http://www.emule-web.de/board/xtreme-mod/)
-   -   eMule 0.49c Mephisto v2.2 [06.10.2009] (http://www.emule-web.de/board/13692-emule-0-49c-mephisto-v2.html)

Stulle 6. July 2008 01:03

eMule 0.49c Mephisto v2.2 [06.10.2009]
 
Liebe Nutzer,

Wie im bei der Veröffentlichung vom letzten ScarAngel versprochen präsentiere ich euch nun den neuen Mephisto. Es gibt nicht viel zu sagen, da sich im Grunde nichts verändert hat. Ich hoffe, dass sich das in der Zukunft ändern wird, aber im Moment sind meine Prioritäten im Leben und beim Programmieren wo anders. Wie dem auch sei, viel Spaß mit dieser Mod.

Zitat:

eMule v0.49c Mephisto v2.2:
------------------------
- 06.10.2009 -
-------------------------------------------------------------------------------
based on eMule 0.49c ScarAngel 3.2 compiled with vs2005 SP1
Download (bin und language):
Mephisto Homepage

-----------------------------------------------------------------------------------------------

Ältere Changelogs:
Zitat:

eMule v0.49b Mephisto v2.1:
------------------------
- 13.10.2008 -
-------------------------------------------------------------------------------
based on eMule 0.49b ScarAngel 3.1 compiled with vs2005 SP1

Changed: Veto new only slot if trickles are transfering [Stulle]


eMule v0.49a Mephisto v2.0:
------------------------
- 06.07.2008 -
-------------------------------------------------------------------------------
based on eMule 0.49a ScarAngel 3.0 compiled with vs2003 SP1

- Xtreme's evil heir -

Added: Drop blocking clients [Stulle]

Changed: Updated libs like the ScarAngel [Stulle]
Changed: Use 0x03 for saving Friendslots to friends.met [ZZ]
Changed: Keep Sup clients in up if there is no other sup client in queue [Stulle]
+ Works a little different, Sup clients are pushed down in upload
Changed: Min Slot number to two (uses "MinSlotsNew" now) [Stulle]

Fixed: Trickle threshold calculation [Stulle]

Remove blocking clients:
+ Upload health has to be 100%
+ Client has to be Full
+ Min Upload to prevent from kick is one tenth of the upload speed or 1 kbyte/s
+ Client has to be receiving for more than 5 minutes
+ Avg block ratio has to be >= 80% or >= 90% in last 20 sec
MFG Stulle :)

eilperius 6. July 2008 08:31

Zitat:

Zitat von Stulle (Beitrag 136991)
... aber ich bitte um euer Verständnis für meine Entscheidung ...

Mein Verständnis hast du ! Auch wenn es mich ebenfalls traurig macht. Die Mod vom Xman wa rmeine erste. Habe sie die ganze Zeit genutzt und werd dann aber jetzt wohl mal umschwenken auf eine neue und aktuelle. Somit denke ich, ich schaue mir nun mal intensiver deine Arbeiten an ...

Ich denke du triffst die richtige Entscheidung bezüglich der Mod von Xman.


greetz eilperius

Stulle 6. July 2008 08:36

Danke. Mir tut es auch leid, aber mich selbst verraten und mich so benutzen lassen möchte ich leider auch nicht. Ich hoffe es gefällt dir, was du siehst. :)

Caramon2 9. July 2008 11:12

Kleiner Schönheitsfehler: Das Startlogo wird nicht angezeigt, wenn "minimert starten" aktiviert ist, egal ob ins Tray, oder normal.

Beim Beenden wird aber das Logo gezeigt, egal ob eMule angezeigt wird, oder im Tray ist, oder ob mit oder ohne Sicherheitsanfrage.

WinXP Home, SP3

Edit: Auf der Homepage steht übrigens "Download older versions of the ScarAngel mod and language sources here (None so far):" (deutsch und englisch) Der Link ist aber richtig.

Stulle 9. July 2008 11:51

mephisto hp is soweit fixed. hab auch noch paar mehr sachen gefunden. ;)

zu deinem schönheitsfehler, wenn minimiert gestartet werden soll halte ich einen splash für wenig zweckmäßig. beim beenden ist das schon sinnvoll, da es ja eh nur mit nutzerinteraktion möglich und der tray zeigt auch an wie es aussieht.

Caramon2 9. July 2008 12:51

Ich hatte erwartet, dass wenn man das Bootlogo aktiviert, es auch kommt.

Dachte, das wäre ein Bug und wollte es melden.

Wenn ich es nicht haben will, deaktiviere ich es eben. (Wie bisher. Hatte ich nur aus ner Laune heraus mal aktiviert, deshalb ist es mir auch erst gar nicht aufgefallen. Hab mich stattdessen gewundert, wieso jetzt beim beenden das Logo kommt. ;) )

Stulle 9. July 2008 15:25

also ich denke minimierten (oder gar versteckten) start hat man vorrangig dann an, wenn man emule auf auto start hat. ich finde es beim booten überaus nervig, wenn erst die ganzen splashs auftauchen. in so fern bin ich ganz froh, wenn es hier nun nicht so ist. ;)

eilperius 9. July 2008 17:25

Zitat:

Zitat von Stulle (Beitrag 137000)
Ich hoffe es gefällt dir, was du siehst.

Bislang sehr sogar ... Werd nur jetzt mal wieder mich mehr in Emule einarbeiten müssen, was die ganzen zusätzlichen Funktionen angeht ... aber "I like the Xtreme's Devil" ... sehr schön und bestimmt ein würdiger Erbe !


greetz eilperius

Caramon2 10. July 2008 10:13

Zitat:

Zitat von Stulle (Beitrag 137044)
also ich denke minimierten (oder gar versteckten) start hat man vorrangig dann an, wenn man emule auf auto start hat. ich finde es beim booten überaus nervig, wenn erst die ganzen splashs auftauchen. in so fern bin ich ganz froh, wenn es hier nun nicht so ist. ;)

Da haben wir wohl unterschiedliche Vorstellungen.

Ich wollte das Boot-Logo eigentlich dazu benutzen, dass ich sehe, wenn eMule geladen ist. Wenn es nicht minimiert gestartet wird, braucht man dafür kein Boot-Logo, weil dann sieht man ja sowieso, wenn es da ist.

Mich nerven die Dinger auch, deshalb habe ich sie überall deaktiviert. Hatte es jetzt nur mal aus dem o.a. Grund aktiviert, da ich eMule momentan manuell starte.

Das Runterfahr-Logo ist für mich dagegen uninteressant, da das hier weniger als eine Sekunde dauert. (kein Backup, kein sicheres Speichern)

Aber wie gesagt: Für mich ist das nicht wichtig. Wer weiß, wie lange ich das überhaupt aktiviert gelassen hätte. Wollte es nur mal ausprobieren.

BernT 10. July 2008 20:46

@ Stulle
ich hatte gestern zwei clients in meiner queue bei denen die modversion "Mephisto a3 v2.0" angezeigt wurde. als ich mir grade mal die source geladen habe musste ich feststellen, dass das in deiner source auch so drinsteht.... aber wenn du schreibst das du auch ein paar schönheitsfehler gefunden hast wird das sicher dabei sein, oder aber es wird dir beim release der v2.1 auffallen. anyway gute arbeit, klasse mod!

Stulle 10. July 2008 20:49

argh, mist, du hast recht. werde das korrigieren. danke für den hinweis. da habe ich eine datei übersehen beim release.

Stulle 11. July 2008 12:51

neue deutsche sprachdatei released. thx an tiboke!

BernT 14. July 2008 12:21

ich hatte ein paar kleine probleme mit dem mephisto, das er hin und wieder abgeschmiert ist und ich nur feststellen konnte das er einfach ausgegangen ist. habe mal die source im debug kompiliert, alle relevanten einstellungen gemacht und siehe da, beim start stürzt der mephisto ab. habe jetzt keine zeit das mit dem scarangel auch zu testen, sry dafür.

bugbeschreibung:
erstmal sei erwähnt, das ich upnp aktiviert habe -> los geht´s
mephisto gestartet, splashscreen läuft durch autoload der ipfilter und antileech läuft durch (btw die antileech wird jedesmal beim start neu geladen - da stimmt was nicht). kad verbindet, erst firewalled, dann offen und dann wird eine crashdmp erstellt. die habe ich dir mal hochgeladen und den screen dazu bekommst du auch. wenn ich nachher zeit habe dann schau ich mal genauer nach -> wird aber wohl ein kad problem sein

eMule_0-49a-23_Mephisto_a3_v2-0_20080714-125851.rar ... at uploaded.to - Free File Hosting, Free Image Hosting, Free Music Hosting, Free Video Hosting, ...

http://img390.imageshack.us/img390/4...istoww3.th.png

eins noch hinterhergeschoben:
wenn ich dann die preferences.ini lösche und den mephisto starte, dann werden erstmal alle files neu geladen (ipfilter, ip2c, antileech) obwohl die im config die gleichen sind. wenn ich dann kad verbinde ist alles in ordnung, verbinde ich server ist auch alles in ordnung. aktiviere ich dann upnp ist alles tutti nur wenn ich dann meinen tmp ordner angebe muss ich neu starten und dann ist der fehler wieder da. versuche später auch mal das manuelle editieren der preferences.ini... irgendwie wird der fehler ja zu finden sein.

Stulle 14. July 2008 14:03

zu der dump, die ist mit der von mir bereit gestellten bin erzeugt, ja?

zu deinem anderen, natürlich läd er das neu (wobei ich bei antileech gerad nicht 100% sicher bin), denn er vergleicht (außer bei antileech) mit einem zeitstempel, der in der pref.ini gespeichert wird. fehlt der vergleichsstempel muss er davon ausgehen, dass neu geladen werden muss.

BernT 14. July 2008 20:36

mit der von dir bereitgestellten bin konnte ich keine dump erzeugen. ich habe deine source ohne änderungen im debug kompiliert und in den von dir bereitgestellten bin die emule(debug).exe ersetzt.

das mit den zeitstempeln, weißt du da die limits? denn da lagen bei der antileech nur 3 minuten zwischen. oder die preferences.ini hatte nen schaden genommen beim dumpen, wäre aber komisch das es dann nur die antileech betrifft und nicht die ipfilter und ip2c. bin jetzt wieder am rechner und werde mir das problem mal genauer zu gemüte führen und alles durchtesten



EDIT:
wärend ich grade getippt habe hat sich der mephisto wieder verabschiedet. erst mit diesem folgenden

http://img172.imageshack.us/img172/7544/hihidj9.th.png

dann nach klicken auf wiederholen mit folgender dump

http://uploaded.to/?id=vyf3cz

EDIT2:
das einzige was ich in der laufzeit geändert hatte war das einfügen eines mit nem anderen mod begonnenen downloads. also tools -> partfiles einfügen. seit ich die part eingefügt habe in die downloads lässt sich der mephisto auch nicht mehr starten und crasht wie anfangs beschrieben


Alle Zeitangaben in WEZ +1. Es ist jetzt 10:18 Uhr.

Powered by vBulletin® Version 3.8.3 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88