[eMule-Web]  

Zurück   [eMule-Web] > eMule > eMule MOD - Development

eMule MOD - Development Alles zum Thema MOD Entwicklung. Fragen, Wünsche, Ideen zu neuen Features.

Antwort
 
LinkBack Themen-Optionen
Alt 31. March 2006, 16:45   #1
Newbie
 
Benutzerbild von LowTech
 
Registriert seit: 13.10.2004
Beiträge: 28
Standard: Kontextmenüs in Selbstauflösung begriffen! Problem: Kontextmenüs in Selbstauflösung begriffen!



Guten Tag, liebe Eselgemeinde!

Ich stehe hier gerade vor einem etwas merkwürdigen Problem.

Ich habe versucht, einen Standard-eMule 0.47a etwas abzuspecken.

Nach dem Entfernen von Scheduler, IRC, Notifier, Webservices und Webserver ging das Kompilieren zwar ohne Probleme und das Programm läuft seit zwei Tagen exzellent und soweit fehlerfrei, allerdings verschwinden die Kontextmenüs nach und nach buchstäblich im Nichts!

Bei jedem Klick auf irgendein Feld des Kontextmenüs im Download-, Such- und Dateifenster werden die Menüeinträge einer nach dem anderen ausgeblendet bis das Menü vollständig "verschwunden" ist.

Ich habe die Vermutung, daß das Problem mit dem entfernten Menüeintrag der Webservices zu tun haben könnte, da dies (zumindest im Suchfenster) die einzige Änderung an dem betroffenen Kontextmenü darstellt.

Leider habe ich bis jetzt keine Lösung des Problems finden können, und wieder einbauen möchte ich das ganze Zeug nun wirklich nicht.

Ich hoffe, daß mir eine(r) von Euch einen Tip geben kann, was ich falsch mache und wie ich mein Problem lösen kann.

Bin für jeden konstruktiven Beitrag dankbar!


Mit besten Grüßen:

LowTech
__________________

Spacewalker 591p Mainboard - VIA Apollo-MVP3 Chipsatz - Pentium MMX 233 MHz CPU - 384 MB SDRAM - Matrox Mystique PCI Grafikkarte - 120 GB Samsung SV1203N - Fiberline 2400TX Gigabit LAN
Windows NT 4.0 Workstation SP 6a


Mulis rennen auch auf LowTech!!!
LowTech ist offline   Mit Zitat antworten
Alt 25. May 2006, 09:47   #2
JvA
MODder
 
Benutzerbild von JvA
 
Registriert seit: 03.01.2004
Beiträge: 135

Hallo LowTech,
ich hatte das selbe Problem als ich damals in meinen Mod die XP-Style Menüs eingebaut habe. dazu waren auch änderungen an den Webservices nötig. Soweit ich mich noch erinnern kann musst du einen part von den Webservices drin lassen und dort aber halt die Anzeige des menüeintrags deaktivieren.....so müsste es theoritisch gehen.....sorry aber es ist schon ne ganze weile her.
was ich aber sicher sagen kann ist, das es 100%-ig an den Webservices liegt!
cya
JvA

JvA ist offline   Mit Zitat antworten
Alt 25. May 2006, 09:57   #3
MODder
 
Benutzerbild von Stulle
 
Registriert seit: 08.04.2004
Beiträge: 7.035

Standard: Kontextmenüs in Selbstauflösung begriffen! Kontextmenüs in Selbstauflösung begriffen! Details

einfach in die pHoeniX sources sehen. dort gibt es für webservices und preview menu den passenden code. problem ist, dass wir nun nicht mehr CMenu oder CTitleMenu haben, sondern CNewMenu (oder so) und daher müßen wir auch die pointer und memberfunktionen für die pointer ändern.

mfg stulle

ps: StulleMule 3.6 wird diesen code enthalten.

__________________
Here comes the Kaiser Von Shizer! Oufweidersehen. with Hanzel und Gretyl

Ja, ich bin Misanthrop!
Stulle ist offline   Mit Zitat antworten
Alt 25. May 2006, 12:23   #4
Senior Member
 
Benutzerbild von Luzifer
 
Registriert seit: 10.10.2005
Beiträge: 325
Standard: Kontextmenüs in Selbstauflösung begriffen! Lösung: Kontextmenüs in Selbstauflösung begriffen!

Du hast nur irgendwo eine Zeile zuviel beim Webservice-Code verschlampt, was bewirkt, dass nach jedem Klick ein Eintrag von unten weniger da ist. Araxis Merge und prost

mfg,
LuZiFeR
Luzifer ist offline   Mit Zitat antworten
Alt 26. May 2006, 01:18   #5
JvA
MODder
 
Benutzerbild von JvA
 
Registriert seit: 03.01.2004
Beiträge: 135
Standard: Kontextmenüs in Selbstauflösung begriffen! Kontextmenüs in Selbstauflösung begriffen! [gelöst]

@stulle: er muss ja desshalb nicht gleich die menüs verbauen......es reicht ja wenn er die zeile von den webservices wieder einbaut.....
cya
JvA
JvA ist offline   Mit Zitat antworten
Antwort

Lesezeichen

Themen-Optionen

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are an



Alle Zeitangaben in WEZ +1. Es ist jetzt 07:37 Uhr.


Powered by vBulletin® Version 3.8.3 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
PAGERANK