[eMule-Web]  

Zurück   [eMule-Web] > eMule > eMule MOD - Development

eMule MOD - Development Alles zum Thema MOD Entwicklung. Fragen, Wünsche, Ideen zu neuen Features.

Antwort
 
LinkBack Themen-Optionen
Alt 27. November 2003, 13:39   #1
Newbie
 
Registriert seit: 27.11.2003
Beiträge: 4
Standard: Compiling Fehler bei Emule 30b TheBlackHand v4 Problem: Compiling Fehler bei Emule 30b TheBlackHand v4



Hi @ll!

Habe da ein Problem... bekomme jedesmal wenn ich die neuen Emule Clients + Mods compile folgende Buildfehler:

c:\emule-source\Src\QueueListCtrl.cpp(725): error C2039: 'AddDebugLogLine' : Ist kein Element von 'CemuleDlg'
c:\emule-source\Src\QueueListCtrl.cpp(725): error C2039: 'AddDebugLogLine' : Ist kein Element von 'CemuleDlg'
c:\emule-source\Src\ServerWnd.cpp(222): error C2065: 'AddLogLine' : nichtdeklarierter Bezeichner
c:\emule-source\Src\ReleaseWnd.cpp(79): error C2065: 'AddLogLine' : nichtdeklarierter Bezeichner
c:\emule-source\Src\emuleDlg.cpp(334): error C2065: 'AddDebugLogLine' : nichtdeklarierter Bezeichner
c:\emule-source\Src\emuleDlg.cpp(368): error C2065: 'AddLogLine' : nichtdeklarierter Bezeichner
c:\emule-source\Src\emuleDlg.cpp(462): error C2039: 'AddDebugLogLine' : Ist kein Element von 'CemuleDlg'
c:\emule-source\Src\emuleDlg.cpp(462): error C2039: 'AddDebugLogLine' : Ist kein Element von 'CemuleDlg'
c:\emule-source\Src\UploadQueue.cpp(1074): error C2039: 'AddDebugLogLine' : Ist kein Element von 'CemuleDlg'
c:\emule-source\Src\UploadQueue.cpp(1074): error C2039: 'AddDebugLogLine' : Ist kein Element von 'CemuleDlg'
c:\emule-source\Src\sockets.cpp(370): error C2039: 'AddDebugLogLine' : Ist kein Element von 'CemuleDlg'
c:\emule-source\Src\sockets.cpp(370): error C2039: 'AddDebugLogLine' : Ist kein Element von 'CemuleDlg'
c:\emule-source\Src\MMServer.cpp(621): error C2039: 'AddDebugLogLine' : Ist kein Element von 'CemuleDlg'
c:\emule-source\Src\MMServer.cpp(621): error C2039: 'AddDebugLogLine' : Ist kein Element von 'CemuleDlg'
c:\emule-source\Src\BaseClient.cpp(347): error C2039: 'AddDebugLogLine' : Ist kein Element von 'CemuleDlg'
c:\emule-source\Src\BaseClient.cpp(451): error C2039: 'AddDebugLogLine' : Ist kein Element von 'CemuleDlg'
c:\emule-source\Src\BaseClient.cpp(471): error C2039: 'AddDebugLogLine' : Ist kein Element von 'CemuleDlg'

kann aber nirgends was entdecken was dazu führt... also entweder steh ich total auf der Leitung oder... ach was weiß ich :( Benötigte Libs sind sowohl als src als auch compiled vorhanden.

Wäre nett wenn mir jemand helfen könnte.

Thx und Gruß


Lampe
lampe ist offline   Mit Zitat antworten
Alt 27. November 2003, 13:43   #2
Gesperrt
 
Registriert seit: 07.03.2003
Beiträge: 452

lampe, Ich glaube dein eintrag gehört hier hin eMule MOD - Development

hackersondope2002 ist offline   Mit Zitat antworten
Alt 27. November 2003, 13:45   #3
Newbie
 
Registriert seit: 27.11.2003
Beiträge: 4
Standard: Compiling Fehler bei Emule 30b TheBlackHand v4 Compiling Fehler bei Emule 30b TheBlackHand v4 Details

ups sorry...

thx werde ihn da posten.

lampe ist offline   Mit Zitat antworten
Alt 27. November 2003, 13:46   #4
Gesperrt
 
Registriert seit: 07.03.2003
Beiträge: 452
Standard: Compiling Fehler bei Emule 30b TheBlackHand v4 Lösung: Compiling Fehler bei Emule 30b TheBlackHand v4

lampe, Ich würde abwarten ich denke er wird dahin noch verschoben.
hackersondope2002 ist offline   Mit Zitat antworten
Alt 27. November 2003, 14:08   #5
MODder
 
Benutzerbild von Xman
 
Registriert seit: 28.03.2003
Beiträge: 5.800
Standard: Compiling Fehler bei Emule 30b TheBlackHand v4 Compiling Fehler bei Emule 30b TheBlackHand v4 [gelöst]

lampe,
lad Dir nochmal neue Sourcen runter. In Deinen Steckt der Wurm drin. Würde jetzt nichts bringen hier ins Detail zu gehen, warum der Fehler kommt.
__________________
Xman ist offline   Mit Zitat antworten
Alt 27. November 2003, 14:19   #6
Newbie
 
Registriert seit: 27.11.2003
Beiträge: 4

DAs problem ist dass selbst beim neu laden der Sourcen wieder der gleiche Fehler kommt.

Oder meinst Du ich soll mir auch die kompletten Libs + Sourcen neu ziehen?

Thx!

Lampe
lampe ist offline   Mit Zitat antworten
Alt 27. November 2003, 14:38   #7
MODder
 
Benutzerbild von Xman
 
Registriert seit: 28.03.2003
Beiträge: 5.800

lampe,
genau das meine ich. Wobei in dem Fall der Fehler nicht in den Libs drinsteckt, sondern ein schlichter Programmierfehler in den Sourcen ist. Vielleicht hast Du irgendeine pre-Version erwischt.
__________________
Xman ist offline   Mit Zitat antworten
Alt 27. November 2003, 14:52   #8
Newbie
 
Registriert seit: 27.11.2003
Beiträge: 4

Hmm mal testen...

Vielen Dank!

Gruß Lampe
lampe ist offline   Mit Zitat antworten
Alt 4. December 2003, 15:31   #9
Newbie
 
Registriert seit: 04.12.2003
Beiträge: 1

sry hab das problem auch und hab mir die source und libs gerade neu gezogen.

greez ed2k
Eddi2k ist offline   Mit Zitat antworten
Alt 4. December 2003, 15:51   #10
MODder
 
Benutzerbild von Xman
 
Registriert seit: 28.03.2003
Beiträge: 5.800

hab noch nie nen kademlia compiliert.... allerdings las ich von solchen Problemen, wenn zuvor nicht erst die id3lib compiliert wurde. Anderes Problem solls geben beim compilieren mit VS2003.
Vielleicht mal das developement-Forum durchsuchen ob ihr da nicht nen Hinweis findet.
www.emule-project.net
__________________
Xman ist offline   Mit Zitat antworten
Antwort

Lesezeichen

Themen-Optionen

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are an


Ähnliche Themen: Compiling Fehler bei Emule 30b TheBlackHand v4


  1. CRC-Fehler bei RAR-files, die mit eMule geladen wurden
    eMule Allgemein - 2. November 2004 (1)
  2. compiling eMule0.30e-sivka.v10e9f ..
    eMule MOD - Development - 16. March 2004 (5)
  3. eMule 0.30b [28.09.03]
    eMule Allgemein - 1. December 2003 (69)
  4. Emule 30b nidrige ID
    Mülltonne - 22. November 2003 (1)
  5. Emule 30b v7
    Mülltonne - 21. November 2003 (2)
  6. Emule 30b v7
    Mülltonne - 21. November 2003 (1)
  7. Emule 30b mit isdn
    eMule Allgemein - 19. October 2003 (5)
  8. eMule 30b Mod 1.1
    Mülltonne - 13. October 2003 (1)
  9. Probleme mit eMule v0.30b
    Mülltonne - 2. October 2003 (3)
  10. Neue eMule Serverlos ? / 0.30b nur noch neben bei ?
    Mülltonne - 28. September 2003 (3)
  11. 2 komische Fehler bei Emule Links
    eMule Allgemein - 26. August 2003 (7)
  12. nach 10min (bei allen emule-versionen) immer gleicher Fehler
    eMule Allgemein - 9. March 2003 (1)


Alle Zeitangaben in WEZ +1. Es ist jetzt 14:22 Uhr.


Powered by vBulletin® Version 3.8.3 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
PAGERANK