[eMule-Web]  

Zurück   [eMule-Web] > eMule > eMule MODs - Allgemein

eMule MODs - Allgemein Alles zu den eMule-MODs, die unsere Anforderungen für 'saubere' MODs erfüllen.

Antwort
 
LinkBack Themen-Optionen
Alt 3. September 2006, 14:10   #1
Advanced Member
 
Registriert seit: 06.07.2006
Ort: Gleich nebenan
Beiträge: 123

Standard: Morph XT öffnet zu viele UL slots => verbraucht  viel CPU und FID hoch Problem: Morph XT öffnet zu viele UL slots => verbraucht viel CPU und FID hoch



Meine Morph XT 8.13 macht bis zu 60 UL Slots auf aber in den Einstellungen ist diese Option
"Slot limitierung auf X Slots" nicht Aktiviert. Durch diese Übermäßig hohe Anzahl von Slots geht der Prozess: "Sytem" auf 30...40% CPU Auslastung und dies wiederum Treibt RM Clock auf Multipler 11x.
Mein Muli ging sonst immer mit ca 10 UL Slots und RM Clock auf Multi 4x.

Jedenfalls steht der Muli mit dem Prozess System in direktem Zusammenhang, weil wenn ich den Muli abschalte geht der Prozess System auf 0 ... 2%. Wenn ich den Muli wieder Anschalte geht der Prozess System gleich wieder Hoch auf 30...40% manchmal auf 65%. Und RM Clock geht daraufhin gleich wieder auf Max.



Ich hab meine UL Kapazität sonst immer auf 60KB/s Limitiert und der Muli ist Supi gelaufen. Habe dann den UL auf 57KB/s eingestellt.

Ist meine Leitung schlechter bzw dünner geworden?

Habe jetzt TaskManager und RightMark Clock beobachtet. Wenn der Muli Startet ist der FID sehr hoch ungefähr 8 Minuten bis alle Quellen abgearbeitet sind. Emule geht auf bis zu 25% CPU und macht spitzen auf über 80...90%.
Nachdem die Quellen abgearbeitet sind geht Emule auf 2...15% und wenn er dann auf über 30% bis zu 70% geht schnippst RM Clock auch gleich mit hoch.

Was verursacht diese hohe CPU Auslastung beim Morph XT.

Laut Statistik geht die CPU auslastung und FID immer bei einer höheren Verbindungrate (so ab 180 Verbindungen) in die Höhe. Und Dieser Zustand ist immer bei der Neuabfrage der Quellen und ab 3 Stunden betrieb ist es immer Hoch CPU und FID.

Router ist ein Fli4L mit 16MB.
__________________
Pistenbully ist offline   Mit Zitat antworten
Alt 4. September 2006, 18:58   #2
Alter Board Hase
 
Registriert seit: 14.11.2005
Ort: RIAA-Gefängniszelle 9
Beiträge: 1.354


Es ist altbekannt, dass das Mulchen eine Uploadslotmania betreibt wenn das Sys ausgelastet ist, das es aber eMule selbst ist was diese Auslastung verursacht klingt seltsam. Könnnte der Router in Sachen gleichzeitige Verbindungen überlastet sein? Hast du mal einen Clean Install von Morph gemacht?

__________________
Pinguine sind süßer als Fenster, selbst wenn diese bunt sind!
Verlierer ist offline   Mit Zitat antworten
Alt 4. September 2006, 23:36   #3
J-R
Junior Member
 
Registriert seit: 03.11.2005
Beiträge: 30
Standard: Morph XT öffnet zu viele UL slots => verbraucht  viel CPU und FID hoch Morph XT öffnet zu viele UL slots => verbraucht viel CPU und FID hoch Details

was die auslastung angeht, das liegt bestimmt an deinem system. bei mir kommt der morph allenfalls in der startphase mal über 50% ansonsten sind es eher 15 und weniger. vielleicht ist es auch ratsam ab und an mal neu zu starten da sich im laufe von mehreren tagen ( wenn er stabil läuft eher wochen) der speicher bedarf deutlich erhöht.
auch eine niedrigere Max Conn je 5sec kann sinnvoll sein da dann die quellenabfrage auf einen grösseren zeitraum ausgedehnt wird, nur die zuviele verbindungen könnte anfangs etwas ansteigen was sich aber nach einiger zeit von selbst regelt.

zu den vielen upload slots habe ich eher die vermutung einer programmier unachtsamkeit.
normalerweise offnet er soviele slots das er mit den eingestellten slotlimits das globale uploadlimit erreicht.
z.b. 20Kb up bei 5Kb je slot bedeutet 4 slots. sollte ein slot nicht genügend abnehmen können merkt das der morph und öffnet einen zusätzlichen um wieder die 20Kb up zu erreichen.

hat man aber nun USS aktiviert und der upload wird automatisch reduziert, bekommt das die slotberechnung vielleicht nicht mit weil sie ja auf das globale limit und nicht das akuelle USS limit verweist und geht von freier upload kapazität aus.
das hat dann zur folge das ein weiterer slot geöffnet wird der das globale limit wegen der USS limitierung ja wieder nicht ausfüllen kann und eher zu einer weiteren reduzierung das USS limits führt wodurch dann wieder ein zusätzlicher slot aktiviert wird...............................

es ist nur eine vermutung ( habe leider vom coden keine ahnung) aber zumindest kann ich bei mir beobachten das bei aktiviem USS immer mehr upload slots geöffnet werden als bei erreichen des globalen upload limits (was aber auch zufall sein kann).


Geändert von J-R (4. September 2006 um 23:46 Uhr)
J-R ist offline   Mit Zitat antworten
Alt 9. September 2006, 14:43   #4
Alter Board Hase
 
Registriert seit: 14.11.2005
Ort: RIAA-Gefängniszelle 9
Beiträge: 1.354

Standard: Morph XT öffnet zu viele UL slots => verbraucht  viel CPU und FID hoch Lösung: Morph XT öffnet zu viele UL slots => verbraucht viel CPU und FID hoch

Da muss ich widersprechen. USS und Slotfokus sind kein Problem, wohl aber schlechte Verbindungen oder wie gesagt glückliche Clients deren Downstream ausgelastet ist, aber das passiert natürlich nicht ununterbrochen.

Wobei bei manchen Version der Fokus bei mir auch miserabel lief, in der 8.13 war er jedoch so sauber wie lange nicht mehr. Von der 8.14 brauchen wir gar nicht erst anfangen...
__________________
Pinguine sind süßer als Fenster, selbst wenn diese bunt sind!
Verlierer ist offline   Mit Zitat antworten
Alt 10. September 2006, 02:16   #5
Advanced Member
 
Registriert seit: 06.07.2006
Ort: Gleich nebenan
Beiträge: 123

Standard: Morph XT öffnet zu viele UL slots => verbraucht  viel CPU und FID hoch Morph XT öffnet zu viele UL slots => verbraucht viel CPU und FID hoch [gelöst]

Also ich habe jetzt die Fehler gefunden:

Mein K8N-E deluxe ist ein Fall für den Versandhandel ich hab ja noch Garantie.
Das war schonmal zur Reperatur (wird nicht mehr Hergestellt, hat sicher zu viele Rückgaben gegeben).
Aber 6 Wochenwill ich ne warten.

Habe jetzt ein K8N-E gekauft (so eine Verschlechterung aber da brauche ich wenigstens keine Neue Hardware) welches bei RedZack seit Wochen rumlag (Sauteuer war des), und musste leider die Feststellung machen das sich die niegelnagelneue 7V300F0 (am 1.8. bestellt) überhaupt nicht mit den Nforce3 verträgt und jetzt geht se überhaupt nicht mehr. Sie lässt sich nicht mal mehr Partitionieren alle möglichen tools durchprobiert. Also auch ab damit zu Reichelt.

Und das wo ich eine HDD komplett extra nur für Muli eingerichtet habe.

Nun denn mal sehen wie der Morph jetzt auf den Funktionstüchtigen System läuft.

Danke für die Antworten

Gruß Pistenbully
__________________
Pistenbully ist offline   Mit Zitat antworten
Antwort

Lesezeichen

Themen-Optionen

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are an


Ähnliche Themen: Morph XT öffnet zu viele UL slots => verbraucht viel CPU und FID hoch


  1. uTorrent verbraucht bei mir zu viele TCP-Verbindungen (43/50)
    Filesharing - 19. January 2013 (2)
  2. UTorrent problem viel viel zu langsam
    Filesharing - 23. August 2011 (2)
  3. Viel zu viele Zu viele Verbindungen mit Phoenix 1.13
    eMule MODs - Allgemein - 27. February 2005 (21)
  4. Morph XT und das komische R/r
    Mülltonne - 21. December 2004 (1)
  5. Abstürze und 100% CPU-Last Pawcio BC MODs
    eMule MODs - Allgemein - 7. September 2004 (4)
  6. [v0-29b Morph v8g] Zu viele Verbindungen
    eMule MODs - Allgemein - 27. October 2003 (4)
  7. Keine Suchergebnisse und viel zu wenig Quellen
    eMule MODs - Allgemein - 8. October 2003 (3)
  8. Download springt hoch und runter
    eMule MODs - Allgemein - 6. October 2003 (17)
  9. Upload hoch =Download hoch?
    Mülltonne - 7. July 2003 (0)
  10. UP/DL Verhältnis viel zu hoch!!!
    eMule MODs - Allgemein - 6. May 2003 (16)
  11. welche emule mod verbraucht wenig cpu und speicher
    eMule MODs - Allgemein - 22. April 2003 (16)
  12. cpu auslastung zwischen 0% und 100%
    eMule Allgemein - 5. March 2003 (3)


Alle Zeitangaben in WEZ +1. Es ist jetzt 06:44 Uhr.


Powered by vBulletin® Version 3.8.3 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
PAGERANK