[eMule-Web]  

Zurück   [eMule-Web] > eMule > eMule MODs - Allgemein

eMule MODs - Allgemein Alles zu den eMule-MODs, die unsere Anforderungen für 'saubere' MODs erfüllen.

Antwort
 
LinkBack Themen-Optionen
Alt 24. June 2010, 00:28   #46
Advanced Member
 
Registriert seit: 26.05.2004
Ort: Dortmund
Beiträge: 113



Zitat:
Zitat von Stulle Beitrag anzeigen
Also funktioniert ClearOnClose, ja? Die Ports werden geschlossen. Dann ist das schon mal okay!
Ja, dauert halt etwa 2 Minuten bis es von der Fritz!Box angezeigt wird.
Port-Checker erkennen den entsprechenden Port schon früher als geschlossen...

Zitat:
Zitat von Stulle Beitrag anzeigen
Wobei es halt auch interessant zu wissen wäre, ob es funktioniert, wenn die Ports geforwarded werden, dann erst die Option eingeschaltet wird, eMule neu gestartet und dann geschlossen wird. Da kann es in der Tat zu Verzögerungen kommen, das liegt dann wohl ein wenig am Router. Gegebenenfalls ruhig mal ein paar Minuten warten.
Versteh' ich nicht.
Sollten dann auch die Ports der ersten Sitzung geschlossen werden?
Ich benutze jede Sitzung andere, also zufällige Ports. Sonst würde ich ja einfach manuell die Standardports freigeben.

Zitat:
Zitat von Stulle Beitrag anzeigen
Zu UPnPForceUpdate so viel, AFAIK verlangen manche Router, dass die ports periodisch erneuert werden, weil sie sonst geschlossen werden. Dafür ist diese Option da, die dann periodisch immer wieder die ports neu freigibt über UPnP beim Router.
Gut zu wissen, dann brauch' ich diese Option wohl gar nicht...

Zitat:
Zitat von Stulle Beitrag anzeigen
Soweit alles klar?
Hoffentlich nicht! Dann gäb's ja nix neues mehr zu entdecken...
__________________
Hiwi ist offline   Mit Zitat antworten
Alt 24. June 2010, 09:33   #47
MODder
 
Benutzerbild von Stulle
 
Registriert seit: 08.04.2004
Beiträge: 7.035


ah, du benutzt random ports, das ist auch interessant zu wissen. naja, wenn du trotzdem mal lust hast stell doch mal bitte feste ports ein und gehe vor wie oben beschrieben um zu gucken was dann passiert. also alles einstellen, UPnP einschalten (ClearOnClose noch aus), eMule schließen, eMule öffnen, ClearOnClose einschalten und dann schließen und mal gucken ob die ports geschlossen worden sind.

__________________
Here comes the Kaiser Von Shizer! Oufweidersehen. with Hanzel und Gretyl

Ja, ich bin Misanthrop!
Stulle ist offline   Mit Zitat antworten
Alt 24. June 2010, 21:48   #48
Advanced Member
 
Registriert seit: 26.05.2004
Ort: Dortmund
Beiträge: 113

Habe mich mit den Ports noch 'mal etwas genauer beschäftigt...

Habe mal den Original emule 0.50a gestartet:
1. Die Standardports werden geöffnet
2. nach Beenden sind die Ports sofort wieder geschlossen(~ 1 Sek.)

Der MorphXT braucht nach dem Beenden bis zu 10 Minuten um die Ports zu schließen.
Das macht aber definitiv nicht der Router eigenständig.

Des Weiteren wundert mich, dass der MorphXT mit der Option "Ports beim Beenden schließen"
einen weiteren, immer anderen, UDP-Port öffnet.

Starte ich den MorphXT mit der Option "Ports beim Beenden schließen"
NACHDEM noch Ports der vorherigen Sitzung geöffnet sind, wird nur der zusätzliche
UDP-Port geschlossen.

Alle Tests habe ich mit den Default-Einstellungen direkt nach entpacken des
Morph gamacht.(abgesehen vom Verbose-Log)

Anbei noch 'mal die Logs und eine chronologische Beschreibung zu meinen Tests:
RapidShare: 1-CLICK Web hosting - Easy Filehosting
RapidShare: 1-CLICK Web hosting - Easy Filehosting
RapidShare: 1-CLICK Web hosting - Easy Filehosting


Gruß
Hiwi

__________________

Geändert von Hiwi (25. June 2010 um 17:45 Uhr)
Hiwi ist offline   Mit Zitat antworten
Alt 24. June 2010, 23:56   #49
MODder
 
Benutzerbild von Stulle
 
Registriert seit: 08.04.2004
Beiträge: 7.035


verbindest du zu servern? das könnte der zusätzliche UDP port sein.

das ports langsamer geschlossen werden kann was mit dem handling wie sie geschlossen werden zusammenhängen. kann sein, dass sie einfach bewusst nur für n minuten gesetzt werden und dann automatisch verfallen. solange sie allerdings geschlossen werden ist IMO alles im grünen bereich.

das ports, die in einer vorherigen session geöffnet worden sind nun nicht geschlossen werden ist grenzwertig... da kann man quasi geteilter meinung sein. zum einen kann es natürlich sagen, dass man ja nicht killen will, was ein anderer erschaffen hat. andererseits sollten sie natürlich gekillt werden, wenn wir sie erschaffen haben. da müsste ich noch mal den code studieren.

das es im übrigen unterschiede zum offi gibt ist klar, die benutzen eine ziemlich andere UPnP implementation!
__________________
Here comes the Kaiser Von Shizer! Oufweidersehen. with Hanzel und Gretyl

Ja, ich bin Misanthrop!
Stulle ist offline   Mit Zitat antworten
Alt 25. June 2010, 17:46   #50
Advanced Member
 
Registriert seit: 26.05.2004
Ort: Dortmund
Beiträge: 113

Zitat:
Zitat von Stulle Beitrag anzeigen
verbindest du zu servern? das könnte der zusätzliche UDP port sein.
Verbindung zu Servern öffnet bei mir keinen weiteren Port. Bei meinen Tests war alles auf Default!
Der zusätzliche UDP-Port öffnet sich eben nur bei ClearOnClose enabled.
Der dritte Anhang in meinem letzten Post erklärt deutlich was ich meine...

Zitat:
Zitat von Stulle Beitrag anzeigen
das ports langsamer geschlossen werden kann was mit dem handling wie sie geschlossen werden zusammenhängen. kann sein, dass sie einfach bewusst nur für n minuten gesetzt werden und dann automatisch verfallen. solange sie allerdings geschlossen werden ist IMO alles im grünen bereich.
Prinzipiell richtig! Rund 10 Min. erschienen mir nur extrem lang...
Oft schließe ich den emule nur kurz, um z.B. einen neuen/anderen Mod zu installieren o.ä.,
und da haben sich früher unbeobachtet halt einige geöffnete Ports(bei Zufallsports) angesammelt

Zitat:
Zitat von Stulle Beitrag anzeigen
das ports, die in einer vorherigen session geöffnet worden sind nun nicht geschlossen werden ist grenzwertig... da kann man quasi geteilter meinung sein. zum einen kann es natürlich sagen, dass man ja nicht killen will, was ein anderer erschaffen hat. andererseits sollten sie natürlich gekillt werden, wenn wir sie erschaffen haben. da müsste ich noch mal den code studieren.
Klar, hier kann man sich streiten...
Ärgerlich wird's eben nur, wenn man den Esel nach dem Beenden zu schnell neu startet, s.o.

Zitat:
Zitat von Stulle Beitrag anzeigen
das es im übrigen unterschiede zum offi gibt ist klar, die benutzen eine ziemlich andere UPnP implementation!
Damit wollte ich zeigen, dass die Verzögerung nicht am Router liegt


Gruß
Hiwi
__________________
Hiwi ist offline   Mit Zitat antworten
Alt 26. July 2010, 02:06   #51
MODder
 
Benutzerbild von Stulle
 
Registriert seit: 08.04.2004
Beiträge: 7.035


neue version^^
__________________
Here comes the Kaiser Von Shizer! Oufweidersehen. with Hanzel und Gretyl

Ja, ich bin Misanthrop!
Stulle ist offline   Mit Zitat antworten
Alt 26. July 2010, 14:33   #52
"Rächer der Genervten"
 
Benutzerbild von Pan Tau
 
Registriert seit: 12.02.2003
Ort: Bei mir zu Haus.
Beiträge: 2.642

Danke!
__________________

Die Welt ist gross, die Welt ist bunt,
ist manchmal grau, doch meistens rund!

Solltest Du sachliche Fehler in meinen Beiträgen finden würde ich mich über eine Nachricht dazu / einen Hinweis darauf freuen. Man lernt nie aus, und ich lerne gerne.
Pan Tau ist offline   Mit Zitat antworten
Alt 5. August 2010, 13:21   #53
Advanced Member
 
Registriert seit: 11.11.2008
Beiträge: 252

Wie kommt das eigentlich das mir der MorphXT alle Einstellungen für den StulleMule6.2 resettet hat?
Hatte den Binärordner entpackt und morphxt exe von nen anderen Ordner aus gestartet. Dann bin ich die Einstellungen durchgegangen. Später als ich den StulleMule neugestartet hab waren sämtliche Daten weg. Dateihistorie, Shared Folder. Auch die TCP/UDP Einstelllungen konnte ich im Router neu einstellen. Weil andere Ports.

War echt schon am verzweifeln. Die Emule exe auf dem Desktop ist mit die StulleMule exe im StulleMule Ordner und hat eigentlich gar nichts mit dem MorphXT Ordner zu tun.

Nutze übrigens Win7 64bit falls das was bedeutet.

Edit: Die Config-Files im Stulle-Ordner scheinen auch noch die selben zu sein. Aber irgendwie lädt der die beim Start der exe nicht mehr.

Geändert von NakedM (5. August 2010 um 13:29 Uhr)
NakedM ist offline   Mit Zitat antworten
Alt 5. August 2010, 14:15   #54
MODder
 
Benutzerbild von Stulle
 
Registriert seit: 08.04.2004
Beiträge: 7.035


dann musst du mal deine einstellungen prüfen. vermutlich werden die settings aus deinem user dir aufgerufen. das musst du selbstständig einstellen und gegebenenfalls umordnen!
__________________
Here comes the Kaiser Von Shizer! Oufweidersehen. with Hanzel und Gretyl

Ja, ich bin Misanthrop!
Stulle ist offline   Mit Zitat antworten
Alt 5. August 2010, 17:46   #55
Advanced Member
 
Registriert seit: 11.11.2008
Beiträge: 252

Weiß auch nicht wie das kommt. Hatte extra die Binary Dateien genommen weil ich keinen INstaller haben wollte und die Dateien so im seperaten Ordner starten wollte. Kann mir nicht erklären wie die exe vom Morph Einfluss auf die Configdateien im Stulle-Mule Ordner haben kann.

Hatte nur noch das hier gefunden:

C:\Users\User\AppData\Local\eMule\config

Anscheined muß ja der Morph als ich die Einrichtung gemacht hatte in Win7 im besagten Pfad nen Ordner angelegt haben. Und als ich Emule exe aussen StulleMule Ordner gestartet habe, bzw vom Desktop, muß dieser auch auf den Ordner zugegriffen haben. Eigentlich wie quasi nen clean-install.

Habe auch schon die alten Config-Datein da reinkopiert aber hat nichts gebracht. Vielleicht hat das bekloppte Win7 noch irgendwo nen "versteckten Ordner" angelegt. Ist zum kotzen damit!
War können nicht die Dateien aus dem selben Ordner genommen werden?
Naja, jetzt habe ich alles neu eingestellt usw wie es vorher war. Hat ein wenig gedauert. Nur doof das meine Statistiken auch weg sind. Und im Freigabe-Ordner wird der Balken für die VErteilung nicht richtig angezeigt. Ist nur schwarz.

Edit: Und kann es sein das es sehr lange dauert mit meine wieder neu im Share geladenen Dateien gefunden werden und Anfragen bekommen? Das hat jetzt teilweise 2-3 Stunden gedauert(und sind immer noch nicht alle gefunden). Habe ne hohe ID. Ports und alles frei. Aber vor nen paar Tagen Router und Kabelmodem für ne Weile vom Netz gehabt und ne neue Ip bekommen. Liegt das vielleicht da dran?

Und Entschuldigung für ein wenig Off_topic hier!

Geändert von NakedM (5. August 2010 um 17:54 Uhr)
NakedM ist offline   Mit Zitat antworten
Alt 5. August 2010, 21:17   #56
MODder
 
Benutzerbild von Stulle
 
Registriert seit: 08.04.2004
Beiträge: 7.035


hab gerad keine lust das alles zu lesen, darum kurz: wenn du eMule auf Vista und höher startest ist der standardpfad für die settings im user path. das ist wegen UAC so gemacht und bewirkt dementsprechend, dass die settings immer die gleichen sind, egal von welchem dir aus emule.exe gestartet wird. es gibt meiner meinung nach ein fall back, wenn die config dateien im programmordner sind, so dass dann diese benutzt werden. wird allerdings nichts gefunden und wir starten, dann setzen wir nen registry eintrag und benutzen das user dir dann für alle.

so, kA ob ich jetzt in meiner erklärungen fehler habe, aber IIRC läuft es so ab. ich bin müde. -.-
__________________
Here comes the Kaiser Von Shizer! Oufweidersehen. with Hanzel und Gretyl

Ja, ich bin Misanthrop!
Stulle ist offline   Mit Zitat antworten
Alt 21. August 2010, 13:40   #57
Junior Member
 
Registriert seit: 31.08.2004
Beiträge: 43

Hallöchen,habe bei der Version 12.4 jetzt auf einmal das Problem, dass sich der komplette Emule aufhängt wenn ich ein File löschen will welches noch nicht komplett gezogen wurde.Das ist sicherlich in 2 von 3 Fällen so.Emule friert ein,Sanduhr und keine Rückmeldung vom Programm Hilft dann nur schliessen und Muli neustarten...

Win7 64bit
Suppenkasper ist offline   Mit Zitat antworten
Alt 21. August 2010, 14:34   #58
Senior Member
 
Benutzerbild von tHe WiZaRd Of DoS
 
Registriert seit: 09.03.2003
Beiträge: 353

Das ist in 100% der Fälle so, du musst aber einfach 2min. warten, dann geht wieder alles.
__________________

God's in his heaven... all's right with the world!
tHe WiZaRd Of DoS ist offline   Mit Zitat antworten
Alt 31. August 2010, 10:27   #59
Junior Member
 
Registriert seit: 31.08.2004
Beiträge: 43

vorher das file stoppen und dann erst auf abbruch,nicht direkt auf abbruch,dann geht´s und der esel friert nichtmehr ein.
Suppenkasper ist offline   Mit Zitat antworten
Alt 23. October 2010, 14:58   #60
MODder
 
Benutzerbild von Stulle
 
Registriert seit: 08.04.2004
Beiträge: 7.035


neue version da^^
__________________
Here comes the Kaiser Von Shizer! Oufweidersehen. with Hanzel und Gretyl

Ja, ich bin Misanthrop!
Stulle ist offline   Mit Zitat antworten
Antwort

Lesezeichen

Themen-Optionen

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are an


Ähnliche Themen: eMule 0.50a MorphXT v12.7 [21.11.2012]


  1. eMule 0.50a ScarAngel v4.2 [22.06.2011]
    Xtreme MOD - 7. March 2017 (15)
  2. emule v0.50a MorphXT v.12.7
    eMule MODs - Allgemein - 13. June 2013 (0)
  3. eMule 0.50a Xtreme 8.1 [03.04.2011]
    Xtreme MOD - 17. April 2011 (2)
  4. eMule 0.50a Mephisto v3.0 [10.04.2011]
    Xtreme MOD - 10. April 2011 (0)
  5. eMule 0.50a Xtreme 8.0 [29.06.2010]
    Xtreme MOD - 14. March 2011 (15)
  6. eMule 0.50a StulleMule v7.0 [25.12.2010]
    eMule MODs - Allgemein - 4. January 2011 (7)
  7. Emule v0.50a
    Filesharing - 19. September 2010 (2)
  8. eMule 0.50a Katana 2.0
    eMule MODs - Allgemein - 15. May 2010 (0)
  9. eMule 0.50a SaintAngel v1.0
    eMule MODs - Allgemein - 15. May 2010 (0)
  10. eMule 0.50a?
    Mülltonne - 24. April 2010 (3)
  11. eMule v0.50a - Tombstone v2.1 [12.04.2010]
    eMule MODs - Allgemein - 12. April 2010 (0)
  12. eMule 0.50a Beta 1 [11.03.2010]
    eMule Allgemein - 20. March 2010 (4)


Alle Zeitangaben in WEZ +1. Es ist jetzt 16:37 Uhr.


Powered by vBulletin® Version 3.8.3 (Deutsch)
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
PAGERANK