[eMule-Web]  

Zurück   [eMule-Web] > Hardware / Software > DSL Router

DSL Router Alles zum Thema Router, sowohl Software als auch Hardware-Lösungen

Antwort
 
LinkBack Themen-Optionen
Alt 13. May 2004, 23:52   #46
Newbie
 
Registriert seit: 13.05.2004
Beiträge: 4
Standard: Portfreigaben für eMule / eDonkey Verrückt



Leute, ich werd langsam verrückt. Seit einigen Stunden les ich FAQs und Forenbeiträgte und frag Google zu dem Problem, aber es will und will nicht funktionieren.

Ich habe einen Level One FBR-1405TX Breitbandrouter an mein DSL-Modem gehängt, an dem u.a. mein PC hängt.
Ich habe Port forwarding für die Ports TCP 4661, 4662 und UDP 4665, 4672 eingestellt und im frisch installierten eMule alle Einstellungen auf Standard gelassen. Eine zusätzliche Firewall ist nicht installiert.
Routerkonfig sieht so aus:


Ich bekomme immer eine Low ID und kann nicht downloaden, aber der Upload zu anderen funktioniert mit voller Geschwindigkeit.
Was ist falsch? Bitte, ihr verhindert einen Suizid

Man findet auch jede Menge widersprüchliche Infos, wenn man viel liest, was soll z.B. das hier im emule-project.net FAQ:
Zitat:
Um dennoch diese Verbindung herstellen zu können müssen der Client Port 4662 TCP, der Webserver Port 4711 und der UDP Port 4672 (dies sind die Standardeinstellung aus Einstellungen -> Verbindung) im Router zu der IP Adresse, auf der eMule läuft, weitergeleitet werden.
Ich mein den Teil mit Webserver Port 4711... muss man das auch forwarden oder ist das Quark? Steht nur an der Stelle und in allen anderen FAQs / Forenbeiträgen steht was anderes.

Muss ich vielleicht noch bei Virtual Server was einstellen? Bin echt am Verzweifeln.
Bitte um Antwort :-/
Brzelius ist offline   Mit Zitat antworten
Alt 14. May 2004, 09:31   #47
Newbie
 
Registriert seit: 14.05.2004
Beiträge: 6

bei meinem dlink 614+ musste ich alle einträge unter virtual server löschen und bei (special) application die ports eintragen. jetzt rennt der muli und keine lowid mehr.

schlabba ist offline   Mit Zitat antworten
Alt 14. May 2004, 10:12   #48
It's cosmic ...
 
Benutzerbild von cosmic girl
 
Registriert seit: 14.01.2003
Beiträge: 3.326


Brzelius
Willkommen an Board!

Auf den ersten Blick sieht für mich eigentlich alles soweit ok aus.
Daher mal eine unumgängliche Frage:
Die lokale IP (oder wie es in der config deines Routers heisst: Private IP), die du da eingetragen hast, ist auch wirklich die, die dein Rechner immer fest hat!?

Ich empfehle dir in dem Zusammenhang den thread von unserem QOS-member CyberCop zu lesen:
http://www.emule-web.de/board/viewtopic.php?t=7839


Ich habe bei mir nur einen TCP und einen UDP port freigegeben, die bewusst nicht die default eMule ports sind - es ist unbedingt zu empfehlen, andere ports zu nehmen! Wenn du eh gerade am Einstellen bist, dann suche dir in eMule zwei neue ports aus (also einen TCP und einen UDP, danach will Muli neugestartet werden). Alles im Bereich 1024 bis 65535 ist möglich und am besten nimmst du einen anderen Abstand als die 10, die bei den default ports sonst üblich sind.
Diese beiden neuen ports trägst du dann in deine port forwarding Liste ein - zusammen mit der richtigen IP deines Rechners.


Den port für den Webserver brauchst du nur freigeben, wenn du vorhast den Webserver auch zu nutzen - damit kannst du von einem anderen Rechner aus deinen Muli "fernsteuern". Obwohl man da zwar nur mit Login und Passwort Zugriff bekommt, ist es auch hier ratsam nicht den default port 4711 (kölnisch Wasser oder wie ? ) zu nutzen.

__________________
cosmic girl ist offline   Mit Zitat antworten
Alt 14. May 2004, 10:14   #49
Newbie
 
Registriert seit: 13.05.2004
Beiträge: 4

Hm... Trigger Ports bei Special Applications... mal schaun wie man die einstellt. Danke für den Tip, mal rumprobieren damit.
Brzelius ist offline   Mit Zitat antworten
Alt 14. May 2004, 10:21   #50
It's cosmic ...
 
Benutzerbild von cosmic girl
 
Registriert seit: 14.01.2003
Beiträge: 3.326


*bump*
Kann sein, dass du meinen post gerade "verpasst" hast.. darum dieser hier.
__________________
cosmic girl ist offline   Mit Zitat antworten
Alt 14. May 2004, 10:21   #51
Newbie
 
Registriert seit: 14.05.2004
Beiträge: 6

Special Application

Name: muli

Trigger Port
4661-4662
Trigger Type
TCP
Public Port
4661-4662

Public Type
TCP

und das gleiche für UDP in meinem beispiel 4665-4672 (ich hatte gelesen das der udp port 4665 hier, ab muli 23 eine funktion hat. also habe ich alle 4 aktiviert)
schlabba ist offline   Mit Zitat antworten
Alt 14. May 2004, 10:26   #52
It's cosmic ...
 
Benutzerbild von cosmic girl
 
Registriert seit: 14.01.2003
Beiträge: 3.326


schlabba
Sieh mal, was ich oben zu den ports geschrieben habe!

Und wahrscheinlich liegt Brzelius' Problem etwas anders, als du hier vermutest.
__________________
cosmic girl ist offline   Mit Zitat antworten
Alt 14. May 2004, 12:57   #53
Newbie
 
Registriert seit: 13.05.2004
Beiträge: 4

@ cosmic girl:
Also, DHCP ist bei mir zwar noch aktiviert, aber das ist Wurst, da mein PC immer die .100 kriegt und der (meist) einzige weitere Rechner in meinem Heimnetz, der Laptop, immer später dazukommt und deswegen immer .101 bekommt. Wie das mit der IP-Vergabe funktioniert, ist klar.

Was ich nicht ganz versteh, ist, warum man nur 2 Ports freigeben muss.
Ich stell zum Bleistift in eMule einen TCP-Port von 8765 und einen UDP-Port von 5678 ein und stell nur diese zwei Ports in die Port-Forwarding-Liste, und alles funktioniert? (theoretisch)

Warum sprechen dann alle FAQs und Anleitungen und längeren Forenbeiträge von 4 Ports?

Naja, ich mach mal ein Update der Router-Firmware, dann muss ich eh alles neu einstellen, kann ich ja gleich mal die Sache mit 2 Spezialports probieren :o)
Brzelius ist offline   Mit Zitat antworten
Alt 14. May 2004, 13:08   #54
The Machine =)
 
Benutzerbild von Pathfinder
 
Registriert seit: 19.08.2003
Beiträge: 4.023


Zitat:
Zitat von Brzelius
Was ich nicht ganz versteh, ist, warum man nur 2 Ports freigeben muss.
Ich stell zum Bleistift in eMule einen TCP-Port von 8765 und einen UDP-Port von 5678 ein und stell nur diese zwei Ports in die Port-Forwarding-Liste, und alles funktioniert? (theoretisch)

Warum sprechen dann alle FAQs und Anleitungen und längeren Forenbeiträge von 4 Ports?
Die Angaben in FAQs und Forenbeiträgen sind natürlich datumsabhängig. Die Zahl der Ports hat sich im Verlauf der eMule-Entwicklung geändert. Derzeit reichen zwei Ports, 1x TCP, 1x UDP.
Eine aktuelle Übersicht findest du auch in der offiziellen FAQ (--> hier).
__________________
filepony.de
Pathfinder ist offline   Mit Zitat antworten
Alt 14. May 2004, 13:14   #55
It's cosmic ...
 
Benutzerbild von cosmic girl
 
Registriert seit: 14.01.2003
Beiträge: 3.326


Zitat:
Zitat von Brzelius
Also, DHCP ist bei mir zwar noch aktiviert, aber das ist Wurst, da mein PC immer die .100 kriegt
Sicher? Kontrollierst du das auch jedesmal?

Zitat:
Zitat von Brzelius
Was ich nicht ganz versteh, ist, warum man nur 2 Ports freigeben muss.
Ich stell zum Bleistift in eMule einen TCP-Port von 8765 und einen UDP-Port von 5678 ein und stell nur diese zwei Ports in die Port-Forwarding-Liste, und alles funktioniert? (theoretisch)
Bei mir funktioniert es praktisch so seit zwei Wochen - solange habe ich meinen Router nun hier laufen.


Zitat:
Zitat von Brzelius
Warum sprechen dann alle FAQs und Anleitungen und längeren Forenbeiträge von 4 Ports?
Gute Frage! So wie ich das mitbekommen habe, braucht man die weiteren ports nur, wenn man selbst einen eD2K-Server betreiben will.

Will mal versuchen den Vorgang kurz und bildhaft zu beschreiben:
Der Router blockt, was von aussen rein will (hier die anderen clients, denen dein Muli seinen TCP/UDP port mitgeteilt hat) - also muss der Router genau diese beiden ports durchreichen zu deinem Muli-Rechner.
Welche anderen ports auch immer die anderen clients verwenden - zu denen connected dein Muli nach draussen und das lässt der Router zu - es sei denn man hat eine Firewall besonders scharf eingestellt.
__________________
cosmic girl ist offline   Mit Zitat antworten
Alt 14. May 2004, 13:33   #56
Newbie
 
Registriert seit: 13.05.2004
Beiträge: 4

Tjo, ich hab neue Firmware auf den Router, Router resetted, alles neu eingestellt, jeweils nur einen Port für TCP und UDP, dasselbe in eMule eingestellt, und jetzt scheint es zu funktionieren.
Jetzt wäre ich glücklich, wenn nicht Pathfinder auf diese offizielle FAQ verweisen würde. Ich nehme mal an, dass die dort erwähnten "überschüssigen" Ports TCP 4661, UDP 4665 (und sowieso TCP 4711) nur für eMule-Server, nicht für Clients gedacht / benötigt sind. Wenn nicht, versteh ich die Sache nicht mehr

Achja, und vielen Dank noch an cosmic girl vor allem
Brzelius ist offline   Mit Zitat antworten
Alt 14. May 2004, 13:44   #57
It's cosmic ...
 
Benutzerbild von cosmic girl
 
Registriert seit: 14.01.2003
Beiträge: 3.326


Bitte, gerne geschehen.

Die offizielle FAQ stimmt schon - schau's dir einfach wann später mal in aller Ruhe noch mal an - dann siehst du es.

Wenn es läuft, dann passt es doch jetzt.
__________________
cosmic girl ist offline   Mit Zitat antworten
Alt 14. May 2004, 13:47   #58
The Machine =)
 
Benutzerbild von Pathfinder
 
Registriert seit: 19.08.2003
Beiträge: 4.023


Zitat:
Zitat von Brzelius
Jetzt wäre ich glücklich, wenn nicht Pathfinder auf diese offizielle FAQ verweisen würde. Ich nehme mal an, dass die dort erwähnten "überschüssigen" Ports TCP 4661, UDP 4665 (und sowieso TCP 4711) nur für eMule-Server, nicht für Clients gedacht / benötigt sind. Wenn nicht, versteh ich die Sache nicht mehr
Verwirren wollte ich dich natürlich nicht, du hast das schon richtig verstanden. 4665 und 4661 sind von deinem Client aus gesehen ausgehend, daher musst du diese Ports im Router nicht berücksichtigen, nur in einer evtl. vorhandenen Firewall freigeben. Es steht auch korrekterweise bei den eingehenden Ports 4662 und 4672 dabei, dass sie in einem Router zu forwarden sind, bei den anderen nicht. Solltest du allerdings einen Server betreiben wollen, so sind diese Ports dann auch weiterzuleiten.
__________________
filepony.de
Pathfinder ist offline   Mit Zitat antworten
Alt 15. May 2004, 14:19   #59
Newbie
 
Registriert seit: 15.05.2004
Beiträge: 4

hallo zusammen,

habe - wie hier durch cosmic girl beschrieben - in der Muli mal den Port 5010 (TCP) und 5030 (UDP) eingestellt und diese sowohl auf der Firewall als auch unter applications auf meinem Router (D-Link DI-624) freigeschaltet...

leider bekomme ihc immer noch eine LowID
Paul Aner ist offline   Mit Zitat antworten
Alt 15. May 2004, 14:38   #60
The Machine =)
 
Benutzerbild von Pathfinder
 
Registriert seit: 19.08.2003
Beiträge: 4.023


Willkommen an Board, Paul Aner!

Zu deinem Routermodell gibt es einen Thread der dir sicher weiterhelfen wird (--> hier). Hättest du über die BoardSuche auch leicht selbst finden können...

[edit: typo]
__________________
filepony.de
Pathfinder ist offline   Mit Zitat antworten
Antwort

Lesezeichen

Themen-Optionen

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are an


Ähnliche Themen: Portfreigaben für eMule / eDonkey


  1. getrennt aus: Portfreigaben für eMule / eDonkey
    Mülltonne - 30. November 2007 (1)
  2. portfreigaben für d-link di 624+
    DSL Router - 24. October 2007 (4)
  3. getrennt aus Portfreigaben für eMule / eDonkey
    Mülltonne - 9. February 2007 (2)
  4. aus für edonkey - es lebe eMule
    eDonkey - Overnet - Kdrive - 18. September 2006 (13)
  5. Portfreigaben für eMule / eDonkey
    Mülltonne - 14. July 2005 (3)
  6. eDonkey inkompatibel zu eMule downloads?
    eDonkey - Overnet - Kdrive - 1. September 2003 (4)
  7. emule oder edonkey ??????????????????
    Mülltonne - 14. July 2003 (1)
  8. emule und edonkey
    eMule Allgemein - 8. July 2003 (5)
  9. Neue Part-Dateien von Edonkey in alte für Emule umwandeln
    eMule Allgemein - 31. May 2003 (3)
  10. edonkey-downloads zu emule kopieren
    eMule Allgemein - 29. May 2003 (5)
  11. Mein Vorschalg für eMule (eDonkey-Hybriden)
    eMule Allgemein - 7. April 2003 (5)
  12. emule/edonkey versionsident
    eMule Allgemein - 7. February 2003 (2)


Alle Zeitangaben in WEZ +1. Es ist jetzt 10:43 Uhr.


Powered by vBulletin® Version 3.8.3 (Deutsch)
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
PAGERANK