[eMule-Web]  

Zurück   [eMule-Web] > eMule > eMule MOD - Development

eMule MOD - Development Alles zum Thema MOD Entwicklung. Fragen, Wünsche, Ideen zu neuen Features.

Antwort
 
LinkBack Themen-Optionen
Alt 18. March 2005, 13:44   #1
Newbie
 
Benutzerbild von LowTech
 
Registriert seit: 13.10.2004
Beiträge: 28
Standard: "failed download sessions" fast bei 90% Problem: "failed download sessions" fast bei 90%



Guten Tag, liebe Grautierfreunde!

Bin schon seit einiger Zeit am Rumbasteln an meinem eigenen kleinen Mod. Prinzipiell läuft es prima, doch ein Problem macht mir dann doch gewaltig Sorgen:

Der Anteil der "failed download sessions" beträgt fast 90%!
Das scheint mir doch entschieden zu hoch zu sein!

Mein Upload beträgt 25 kB/s (von 32 kB/s Maximum), der Download ist unlimitiert.
Am "Abwürgen" des Downloades durch einen zu hohen Upload sollte es also nicht liegen.

Ich beobachte häufig, daß Clients in den Download-Status kommen, dort einige Sekunden mit 0 KB/s verharren um sich dann wieder zu verabschieden.


Daraus ergeben sich für mich einige Fragen:

- Welche Rate von "failed download sessions" ist als normal anzusehen?
Ich würde mich freuen, wenn einige von Euch mal posten könnten, was sie da so für Werte haben.

- Es wäre prima, wenn mir vielleicht jemand aus dem Kreis der Profi-Modder einen Tip geben könnte, an welchen Stellen im Quellcode genau die Ursachen liegen könnten?

Vielleicht ist das Problem ja längst bekannt, gelöst und ein Fix verfügbar? Wär' ja nicht das erste Mal...


Bin für jede Hilfe dankbar!

Beste Grüße!

LowTech
__________________

Spacewalker 591p Mainboard - VIA Apollo-MVP3 Chipsatz - Pentium MMX 233 MHz CPU - 384 MB SDRAM - Matrox Mystique PCI Grafikkarte - 120 GB Samsung SV1203N - Fiberline 2400TX Gigabit LAN
Windows NT 4.0 Workstation SP 6a


Mulis rennen auch auf LowTech!!!
LowTech ist offline   Mit Zitat antworten
Alt 18. March 2005, 13:54   #2
MODder
 
Benutzerbild von Stulle
 
Registriert seit: 08.04.2004
Beiträge: 7.035


Bin zwar kein Profi-Modder, aber auch ein solcher könnte dir nicht genau sagen woran es liegt ohne a) die features/ änderungen in deinem mod gesehen zu haben und/ oder b) den quellcode gesehen zu haben.
Also sag ma was de geändert hast und gib uns vielleicht ma deine sources.

mfg stulle

__________________
Here comes the Kaiser Von Shizer! Oufweidersehen. with Hanzel und Gretyl

Ja, ich bin Misanthrop!
Stulle ist offline   Mit Zitat antworten
Alt 22. March 2005, 00:50   #3
Newbie
 
Benutzerbild von LowTech
 
Registriert seit: 13.10.2004
Beiträge: 28
Standard: "failed download sessions" fast bei 90% "failed download sessions" fast bei 90% Details

Guten Morgen!

es scheint, als daß ich das Problem gefunden habe!

Systematischer partieller "Rückbau" des Mod's führt zu dem Ergebnis, daß ich offenbar den "Chunk-Selektion-Patch" von Xman irgendwie falsch implementiert haben muß.

Nach Deaktivierung des Patches habe ich jetzt nach ca. 10 Stunden Laufzeit eine Rate an "failed download sessions" von 28,6% und deutlich bessere Downloadraten.

es handelt sich um folgenden Abschnitt der PartFile.cpp:

Zitat:

// Maella -Code Improvement-
for (POSITION pos = srcList.GetHeadPosition(); pos != 0; ){
cur_src = srcList.GetNext(pos);
// Test if the source has already transfered its list of parts
if(cur_src->GetPartCount() == partcount){

//Xman better chunk selection
//use different weight
uint8 weight=2;
if(cur_src->GetDownloadState()==DS_ONQUEUE && (cur_src->IsBanned() || cur_src->IsRemoteQueueFull() || cur_src->GetRemoteQueueRank()>4000))
weight=1;
//Xman end

const uint8* pPartStatus = cur_src->GetPartStatus();
for(uint16 i = 0; i != partcount; i++){
if(pPartStatus[i] != 0)
{
m_SrcpartFrequency[i] +=weight; //Xman better chunk selection
}
}
cur_count= cur_src->GetUpCompleteSourcesCount();
if ( flag && cur_count )
{
count.Add(cur_count);
}
}
}
// Maella end

//Xman better chunk selection
//at this point we have double weight -->reduce to normal (division by 2)
for(uint16 i = 0; i < partcount; i++)
{
if(m_SrcpartFrequency[i]>1)
m_SrcpartFrequency[i] = m_SrcpartFrequency[i]>>1; //nothing else than ceil((float)m_SrcpartFrequency[i]/2) ;
}
//Xman end
Hab ich da irgendwo (in anderen Source-Files?) irgendwas (weiteren zum Patch gehörenden Code?) vergessen?
Habe mir das alles nochmal angeschaut und finde selber keinen Fehler.
Andere Mod's haben ja auch keinerlei Schwierigkeiten mit diesem Patch.

Beste Grüße!

LowTech

__________________

Spacewalker 591p Mainboard - VIA Apollo-MVP3 Chipsatz - Pentium MMX 233 MHz CPU - 384 MB SDRAM - Matrox Mystique PCI Grafikkarte - 120 GB Samsung SV1203N - Fiberline 2400TX Gigabit LAN
Windows NT 4.0 Workstation SP 6a


Mulis rennen auch auf LowTech!!!
LowTech ist offline   Mit Zitat antworten
Alt 22. March 2005, 07:06   #4
MODder
 
Benutzerbild von Xman
 
Registriert seit: 28.03.2003
Beiträge: 5.800
Standard: "failed download sessions" fast bei 90% Lösung: "failed download sessions" fast bei 90%

welche Basisversion benutzt Du denn eigentlich ?
Mich wundert nämlich: es handelt sich hier nicht um den veröffentlichten Patch, sondern um eine Version aus dem Xtreme2.2
Da nur der Xtreme2.2 die sourceList auf die Abgebildete Art und Weise benutzt, schätze ich sogar Du nutzt den Xtreme2.2 als Codebasis. Dann bräuchtest Du aber den Patch nicht
Falls Du die 0.45a/b als Basis nimmst sollte der ganz eCode nicht laufen, denn in diesen Versionen ist die sourcelist zwar wie im Xtreme2.2 verwaltet (haben da die offiziellen abgekupfert ?*g*) allerdings würde es dann heißen "sourcelist" und nich twie bei Dir "sourceList".
Was mich insgesamt zum Ergebnis führt: Du scheinst sehr vieles aus dem Xtreme genommen zu haben... allerdings ist dessen Code teilweise so komplex, daß ich Dir nicht so einfach sagen kann, was genau der Fehler ist.
__________________
Xman ist offline   Mit Zitat antworten
Alt 31. March 2005, 02:30   #5
Newbie
 
Benutzerbild von LowTech
 
Registriert seit: 13.10.2004
Beiträge: 28
Standard: "failed download sessions" fast bei 90% "failed download sessions" fast bei 90% [gelöst]

Zitat:
Zitat von Xman
welche Basisversion benutzt Du denn eigentlich ?
Mich wundert nämlich: es handelt sich hier nicht um den veröffentlichten Patch, sondern um eine Version aus dem Xtreme2.2
Ich verwende den emule 0.44d Webcache als Basis.
Habe daran aber mittlerweile derart viel herumgebastelt, daß er mit diesem kaum noch etwas gemein haben dürfte.

Zitat:
Da nur der Xtreme2.2 die sourceList auf die Abgebildete Art und Weise benutzt, schätze ich sogar Du nutzt den Xtreme2.2 als Codebasis. Dann bräuchtest Du aber den Patch nicht
Ich benutze keinen Xtreme als Basis habe aber, wie von Dir richtig bemerkt, den Patch aus der Source Deines 2.2 entnommen.

Zitat:
Falls Du die 0.45a/b als Basis nimmst sollte der ganz eCode nicht laufen, denn in diesen Versionen ist die sourcelist zwar wie im Xtreme2.2 verwaltet (haben da die offiziellen abgekupfert ?*g*) allerdings würde es dann heißen "sourcelist" und nich twie bei Dir "sourceList".
Tja, nachdem der Compiler sich über die fehlende Deklaration von "srclist" beschwert hat, änderte ich das Ganze einfach in "srcList" .
Mag sein, daß hier der Fehler lag.

Zitat:
Was mich insgesamt zum Ergebnis führt: Du scheinst sehr vieles aus dem Xtreme genommen zu haben... allerdings ist dessen Code teilweise so komplex, daß ich Dir nicht so einfach sagen kann, was genau der Fehler ist.
Eigentlich habe ich mir die Source in erster Linie wegen Deines Patches runtergeladen, aber nachdem das ja nicht funktionierte habe ich Deinen auf emule-project.net geposteten Code erfolgreich verbaut.

Vielen Dank für Deine großartige Programmierarbeit
und allerbeste Grüße!

LowTech
__________________

Spacewalker 591p Mainboard - VIA Apollo-MVP3 Chipsatz - Pentium MMX 233 MHz CPU - 384 MB SDRAM - Matrox Mystique PCI Grafikkarte - 120 GB Samsung SV1203N - Fiberline 2400TX Gigabit LAN
Windows NT 4.0 Workstation SP 6a


Mulis rennen auch auf LowTech!!!
LowTech ist offline   Mit Zitat antworten
Antwort

Lesezeichen

Themen-Optionen

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are an


Ähnliche Themen: "failed download sessions" fast bei 90%


  1. Wird ein "download" bei utorrent fortgesetzt, wenn PC aus ist?
    Filesharing - 2. February 2011 (2)
  2. Bluescreen "BAD POOL CALLER" beim "eseln"
    Hard- und Software Allgemein - 30. June 2008 (8)
  3. Was bedeuet "Failed-Download-Ban"
    Xtreme MOD - 6. March 2007 (6)
  4. "Keine Rückmeldung" bei Download
    eMule Allgemein - 15. October 2006 (8)
  5. Kann "Portforwarding" und/oder "Portmapping" nicht finden
    DSL Router - 14. August 2005 (7)
  6. Wieviele "Fehlgeschlagene Download Sessions"?
    eMule Allgemein - 21. July 2005 (21)
  7. Was sind "Fehlgeschlagene Upload-Sessions" im Detail?
    eMule Allgemein - 14. June 2005 (3)
  8. Zu viele "Failed Download Sessions"
    eMule MODs - Allgemein - 20. April 2004 (6)
  9. Download "fast" nur von eDonkeyHybrid
    eMule MODs - Allgemein - 26. March 2004 (4)
  10. Nach Update - "failed to create server udp port"
    eMule Allgemein - 6. September 2003 (0)
  11. "blockieren" und "verstecken" von parts?
    eMule MODs - Allgemein - 28. July 2003 (13)


Alle Zeitangaben in WEZ +1. Es ist jetzt 00:14 Uhr.


Powered by vBulletin® Version 3.8.3 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
PAGERANK