[eMule-Web]  

Zurück   [eMule-Web] > Einsteiger Bereich > eMule für Neulinge - und auch alte Hasen

eMule für Neulinge - und auch alte Hasen Alles Wissenswerte für einen guten Start. Einstellungstips & FAQ. Troubleshooting, wenn Muli nicht so recht mag.

Antwort
 
LinkBack Themen-Optionen
Alt 14. June 2005, 21:29   #1
Newbie
 
Registriert seit: 14.06.2005
Beiträge: 3
Standard: warum müllt emule den Arbeitsspeicher so zu? Problem: warum müllt emule den Arbeitsspeicher so zu?



AAAh! irgendwie hat das posten nicht geklappt, deswegen nur in urzform:

Mich interessiert schon länger warum emule binnen weniger Tage den verbrauch an Arbeitsspeicher verdoppelt. selbst wenn massig neue clients und dateien dazu kommen kann das nicht >50MB RAM erklären (zumal in den Dateien known und clients.dat zusammen 10 MB schon riesig sind)
Die logs sind ja nur text und können das auch nicht bewirken - ein löschen der logs bringt auch nicht viel weniger speicherverbrauch (was zu erwarten ist)

ich wüsste beim betsen willen nicht was sich da ansammeln sollte - alles andere sind doch nichts als integer-Werte (oder real bei kommazahlen), di auch nur sehr wenig platz belegen
n00b ist offline   Mit Zitat antworten
Alt 15. June 2005, 08:44   #2
MODder
 
Benutzerbild von Xman
 
Registriert seit: 28.03.2003
Beiträge: 5.800

Intergerwerte, Fließkommawerte und Strings... aber davon eine ganze Menge!

__________________
Xman ist offline   Mit Zitat antworten
Alt 16. June 2005, 11:00   #3
Newbie
 
Registriert seit: 14.06.2005
Beiträge: 3
Standard: warum müllt emule den Arbeitsspeicher so zu? warum müllt emule den Arbeitsspeicher so zu? Details

und woher kommen die bzw wozu sind die notwendig?

versteht mich nicht falsch, ich will mich nicht beschweren - nur verstehen....

n00b ist offline   Mit Zitat antworten
Alt 16. June 2005, 11:07   #4
MODder
 
Benutzerbild von Xman
 
Registriert seit: 28.03.2003
Beiträge: 5.800
Standard: warum müllt emule den Arbeitsspeicher so zu? Lösung: warum müllt emule den Arbeitsspeicher so zu?

für jeden client müssen eine unzählige Menge an Informationen gespeichert werden:
- welche Protokollfeatures unterstützt er
- wann muß er wieder gefragt werden
- Userhash, IP, Port, Kad-Buddy usw.
- Informationen welche Chunks er hat, welche er braucht
und vieles vieles vieles mehr

und ebenso werden noch nen Menge Informationen für jedes File gespeichert
__________________
Xman ist offline   Mit Zitat antworten
Alt 29. June 2006, 11:58   #5
Moderator
 
Benutzerbild von Myth88
 
Registriert seit: 12.12.2005
Beiträge: 3.156

Standard: warum müllt emule den Arbeitsspeicher so zu? warum müllt emule den Arbeitsspeicher so zu? [gelöst]

...also ist es normal, das der muli nach ca. 17 std. laufzeit in etwa 380 MB ram verbraucht?
mir ist es eigentlich egal, aber wenn man dann mal ein kompliziertes game spielen mag, ist das schon etwas "unpraktisch"...

mfg myth88
__________________
Bitte die BoardRules beachten!
Vor dem Posten bitte Checkliste vor dem Posten lesen und die Forensuche verwenden!

Myth88 ist offline   Mit Zitat antworten
Alt 29. June 2006, 12:32   #6
Board Methusalem
 
Benutzerbild von Januar1956
 
Registriert seit: 08.06.2003
Beiträge: 2.096

Zitat:
Zitat von Myth88
...also ist es normal, das der muli nach ca. 17 std. laufzeit in etwa 380 MB ram verbraucht?
mir ist es eigentlich egal, aber wenn man dann mal ein kompliziertes game spielen mag, ist das schon etwas "unpraktisch"...

mfg myth88
Nein, natürlich nicht. In der Regel sollten ~ 80 - kurzzeitig ~ 150 MB Ram locker ausreichen. Also alles abschalten, was man nicht braucht, insbesondere die Quellenspeicherung und SUQWT, die für den "Normalo" sowieso Blödsinn ist und auch nix bringt.

Januar
Januar1956 ist offline   Mit Zitat antworten
Alt 29. June 2006, 13:34   #7
Senior Member
 
Benutzerbild von Luzifer
 
Registriert seit: 10.10.2005
Beiträge: 325

Und IP2Country deaktivieren bzw die betreffenden Files aus dem Config-Ordner entfernen bringt aucht ganz schön was
Luzifer ist offline   Mit Zitat antworten
Alt 30. June 2006, 23:08   #8
Moderator
 
Benutzerbild von Myth88
 
Registriert seit: 12.12.2005
Beiträge: 3.156


hi leute und danke für eure antworten...habe das prob nach langem suchen in meinen einstellungen gefunden: max halboffene verbindungen war auf 100! auf 40 gestellt und schon gelöst. (verbraucht so 78 MB dauerhaft, und macht auch keine spitzen mehr).

myth88

ps. falls mein muli wieder anfängt die RAM zu fressen, poste ich wieder....

edit: scheint doch nicht daran zu liegen, denn ich habe gerade reingeschaut, (ich hatte ein backup vom config-ordner) und jetzt war wieder auf 100 und trotzdem 78 MB RAM....habe jetzt aber wieder auf 40 gestellt, denn mit 100 waren das meiner meinung nach zu viele...

edit: wieder 140 MB ram-verbrauch, was aber noch in ordnung ist...bei 1 GB insgesamt.... *grins*
__________________
Bitte die BoardRules beachten!
Vor dem Posten bitte Checkliste vor dem Posten lesen und die Forensuche verwenden!


Geändert von Myth88 (1. July 2006 um 09:55 Uhr)
Myth88 ist offline   Mit Zitat antworten
Alt 1. July 2006, 13:41   #9
Gesperrt
 
Benutzerbild von harzflirt
 
Registriert seit: 05.06.2006
Beiträge: 23

na wie weiter oben schon gesagt es müssen viele infos geladen werden. siehs so wie bei google erth. wo die weltkugel in den RAM geladen wird!

mfg
harzflirt
harzflirt ist offline   Mit Zitat antworten
Alt 1. July 2006, 14:19   #10
Moderator
 
Benutzerbild von Myth88
 
Registriert seit: 12.12.2005
Beiträge: 3.156


ja-ja, ich seh da ja auch gar kein problem, solange der ram-verbrauch um die 100 MB bleibt.
aber neulich hatte er wohl 'ne macke, (bis auf 600 MB ram) und dann um ihn zu schließen hat es ca. 10 min gedauert...vielleicht wegen zu wenig platz auf der muli-hd... habe aber auch gerade eine neue 120 GB bestellt...

mfg
myth
__________________
Bitte die BoardRules beachten!
Vor dem Posten bitte Checkliste vor dem Posten lesen und die Forensuche verwenden!

Myth88 ist offline   Mit Zitat antworten
Alt 2. July 2006, 10:21   #11
Gesperrt
 
Benutzerbild von harzflirt
 
Registriert seit: 05.06.2006
Beiträge: 23

stimmt da hatte er ne macke! so ne nummer schaft bei mir nur google erth! er wird schich wohl verabschiedet haben (=abgestürzt). du hättes natürlich auch "Strg+Alt+Enft" drücken können und die anwendung selber schließen können. ich will, aber nich sagen ob da ein daten verlust nich auschließen wäre!

mfg
harzflirt
harzflirt ist offline   Mit Zitat antworten
Alt 2. July 2006, 11:19   #12
Moderator
 
Benutzerbild von Myth88
 
Registriert seit: 12.12.2005
Beiträge: 3.156


das mit dem task-manager und dann den prozess zu schließen ist keine gute idee, denn dann sind die daten weg, oder die met's beschädigt....aber jetzt hat sich mein muli wieder "eingependelt", 50-70 MB ram und scheint auch so zu bleiben....
jetzt ist er wieder so wie vom xtreme gewohnt: schnell und stabil!!!
grüße
myth88
__________________
Bitte die BoardRules beachten!
Vor dem Posten bitte Checkliste vor dem Posten lesen und die Forensuche verwenden!

Myth88 ist offline   Mit Zitat antworten
Alt 2. July 2006, 11:22   #13
Gesperrt
 
Benutzerbild von harzflirt
 
Registriert seit: 05.06.2006
Beiträge: 23

wie von mir oben |^ gesagt, ich will den daten verlust ja nich ausschließen. außerdem wäre mir das erstma egal, denn wenn sich mein rechner verabschiedet sind auf jeden fall mehr daten weg!
harzflirt ist offline   Mit Zitat antworten
Alt 10. August 2006, 16:41   #14
Gesperrt
 
Registriert seit: 24.12.2005
Beiträge: 16

Zitat:
Zitat von n00b
AAAh! irgendwie hat das posten nicht geklappt, deswegen nur in urzform:

Mich interessiert schon länger warum emule binnen weniger Tage den verbrauch an Arbeitsspeicher verdoppelt. selbst wenn massig neue clients und dateien dazu kommen kann das nicht >50MB RAM erklären (zumal in den Dateien known und clients.dat zusammen 10 MB schon riesig sind)
Die logs sind ja nur text und können das auch nicht bewirken - ein löschen der logs bringt auch nicht viel weniger speicherverbrauch (was zu erwarten ist)

ich wüsste beim betsen willen nicht was sich da ansammeln sollte - alles andere sind doch nichts als integer-Werte (oder real bei kommazahlen), di auch nur sehr wenig platz belegen
Das ist doch noch gar nichts.

Guck mal Zone Alarm den Müll an.

Mann macht das Ding an, der Ram Verbrauch liegt bei 10 MB.

Ok jetzt schaut man mal ein paar Tage später und dann sind es schon mal über 200MB Verbrauch, nur weil ZA jeden erdenklichen kleinen Mist(IMCP usw) als ""Angriff"" zählt.

Und zu mies programmiert ist, um den Speicher zu bereinigen, selbst ich Noob Programmierer hätte das hingekriegt.

Früher als ich noch Bruteforcen betrieben habe, hat der Mist jeden Request nach aussen von meinem Bruteforce Prog als ""abgewehrten Angriff"" gezählt.

Da stand dann schon mal so was wie.

"ZA hat in 9 Tagen 150.000 Angriffe abgewehrt"

Emule selber verbraucht, natürlich einiges.

Massig Strings, Hash Werte usw usw
Slut-Hunter ist offline   Mit Zitat antworten
Alt 10. August 2006, 18:58   #15
Board-Marsupilami
 
Benutzerbild von Sorrow
 
Registriert seit: 15.05.2005
Ort: Dschungel von Palumbien
Beiträge: 2.097

...hallo Slut-Hunter...
Zitat:
Zitat von Slut-Hunter
Das ist doch noch gar nichts.
Guck mal Zone Alarm den Müll an.
...wie es dir unschwer entgangen sein sollte, geht es hier um die erklärung, warum eMule den speicher so "vollmüllt", und nicht zig andere programme...

...ps: dass ZA und andere personal-firewalls den arbeitsspeicher "übermässig" nutzen, ist ,nebenbei bemerkt, schon lange bekannt...


Sorrow
__________________
if (ahnung == 0) { read FAQ; use SEARCH; use GOOGLE; } else { use brain; make post; }



Diskutiere nie mit Idioten - sie holen Dich auf ihr Niveau und schlagen Dich dort mit Erfahrung

*** Disk Error /dev/hda: - Wasser im Laufwerk (Bitte abpumpen) ***
Sorrow ist offline   Mit Zitat antworten
Antwort

Lesezeichen

Themen-Optionen

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are an


Ähnliche Themen: warum müllt emule den Arbeitsspeicher so zu?


  1. Warum niedrige ID bei emule?
    Filesharing - 11. September 2008 (2)
  2. Vista Ultimate 32bit mit 4Gigabyte Arbeitsspeicher
    Hard- und Software Allgemein - 11. August 2007 (12)
  3. Nach Trennung der DSL-Verbindung, durch den Provider und dabei laufenden Muli dauert es lange bis DLs wieder starten. Warum?
    eMule Allgemein - 19. July 2007 (12)
  4. zugriff auf den incoming-ordner lässt den explorer abstürzen
    eMule für Neulinge - und auch alte Hasen - 26. March 2006 (14)
  5. Warum benutzten so viel emule???
    Mülltonne - 4. May 2005 (4)
  6. Warum Emule???
    Mülltonne - 4. May 2005 (1)
  7. Arbeitsspeicher!!
    Mülltonne - 2. March 2005 (4)
  8. Welches mod bietet den Servernamen mit den meisten Hits?
    eMule MODs - Allgemein - 13. January 2004 (7)
  9. Warum fliegt mein eMule so oft von den Servern?
    eMule Allgemein - 6. January 2004 (5)
  10. Was soll ich den mit den bin`s??
    Mülltonne - 4. August 2003 (1)
  11. Warum wechselt emule eigentlich immer den Server????
    eMule Allgemein - 4. February 2003 (9)
  12. Kann den film den ich mir mit eMule runtergeladen habe nich
    Mülltonne - 1. February 2003 (0)


Alle Zeitangaben in WEZ +1. Es ist jetzt 23:04 Uhr.


Powered by vBulletin® Version 3.8.3 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
PAGERANK