[eMule-Web]  

Zurück   [eMule-Web] > eMule > eMule MODs - Allgemein

eMule MODs - Allgemein Alles zu den eMule-MODs, die unsere Anforderungen für 'saubere' MODs erfüllen.

Antwort
 
LinkBack Themen-Optionen
Alt 1. June 2008, 06:21   #46
Advanced Member
 
Benutzerbild von fafner
 
Registriert seit: 15.01.2004
Ort: Nünädachzgnullzwei
Beiträge: 205



@tango2002a

Es ist halt so, daß man Mods ja für sich macht auf den Rechnern die man hat. Bei mir ist der Mulirechner 'n P4 1,8 GHz 768 MB und da läuft der StulleMule 6.0 ganz passabel (auch mit 4500 Quellen).

Nun wird der aber demnächst ersetzt durch 'n P4 2,13 GHz 2 GB. Also ja, PIII ist immer weniger geeignet.


@MickiKrause

"Download ist schlechter" gehört leider in die Kategorie "gefühlte Probleme" und daher ist der Nachweis schwierig bis unmöglich. Ich kann hier z.B. nix feststellen, kriege von Leuten mit der passenden Leitung über 2 MB/s.
__________________
__________________________
"Ich finde das Furcht erregend." - Cameron Diaz in einem Spiegel-Interview, 18.3.2005
Heißt es nicht mehr "die Furcht"?
fafner ist offline   Mit Zitat antworten
Alt 1. June 2008, 09:15   #47
MODder
 
Benutzerbild von Stulle
 
Registriert seit: 08.04.2004
Beiträge: 7.035


richtig fafner, habe auch nen p4 in der größenordnung, allerdings mit 1.5 GB ram.

micki, auch hier hat fafner recht. such einfach mal im board nach wenig download, da wirst du sehen, dass der download praktisch nie von der mod abhängt und wenn er davon abhängt, dann sind gravierende fehler im programmcode, was ich an dieser stelle aber für den stullemule ausschließen kann!

__________________
Here comes the Kaiser Von Shizer! Oufweidersehen. with Hanzel und Gretyl

Ja, ich bin Misanthrop!
Stulle ist offline   Mit Zitat antworten
Alt 1. June 2008, 11:28   #48
Junior Member
 
Registriert seit: 18.10.2005
Beiträge: 35

@fafner
Du hast sicher Recht mit der Annahme, dass ein PIII-System für den neuen Stulle nicht optimal geeignet ist. Bisher habe ich es aber trotzdem geschafft den StulleMule zu integrieren und erreiche für mein System sehr gute DL-Ergbnisse (UL 1 : DL 2,x). Das wäre mit meinem Hauptrechner (P IV) nicht zu schaffen, da ich mit diesem nicht ständig online präsent wäre. Im übrigen hätte es ja sein können, dass der eine oder andere Tester vielleicht auch mal mit einem Gurkenrechner, der nur für den Muli optimiert ist, online geht.

Für eine Steigerung meines DLs wäre keine neue Version erforderlich. Interessant wäre für mich eine bessere Performance (Stabilität) zu erreichen und die aktuelle Leecherkennung zu integrieren damit eine bessere Verteilung der Dateien gewährleistet ist.


@Stulle
Ich bin seit Jahren von Deinen Mod-Versionen begeistert. Den ZZUL habe ich zugunsten der Stabilität etwas entschärft. Da die Mod mit allen clients gut zusammenarbeitet, wird alles in extrem kurzer Zeit fertig. Dabei spielt es keine Rolle welche Version ich aufspiele. Dafür ein großes Lob.

Der Rechner friert bei mir ständig ein, wenn ein sehr starker Anstieg der Verbindungen vorliegt. Nach dem Einfrieren fängt er nach ein paar Minuten wieder an zu laden. Nach ca. 15 Minuten steigen die Verbindungen schlagartig an und er lädt mit 200 KB/s. Nach dem Erreichen des Verbindungslimits friert er dann ca. 2 Minuten ein,so dass er alle Verbindungen verliert. Auch wenn ich den Router von 400 auf 150 Verbindungen umstelle passiert das gleiche. Vielleicht ist die 6.0 Version einfach zu schnell.

tango2002a ist offline   Mit Zitat antworten
Alt 1. June 2008, 12:00   #49
MODder
 
Benutzerbild von Stulle
 
Registriert seit: 08.04.2004
Beiträge: 7.035


wie wäre es, wenn du einfach mal versuchst ein wenig last vom muli zu nehmen? kein - und ich betone KEIN - emule client ist dafür gedacht bis aufs letzte ausgereizt zu werden. wenn du mehrere hundert connections hast musst du dich eigentlich nicht wundern!

edit: btw, mal versucht als service laufen zu lassen? nimmt etwas mehr last vom rechner.
__________________
Here comes the Kaiser Von Shizer! Oufweidersehen. with Hanzel und Gretyl

Ja, ich bin Misanthrop!

Geändert von Stulle (1. June 2008 um 12:02 Uhr)
Stulle ist offline   Mit Zitat antworten
Alt 1. June 2008, 12:20   #50
Junior Member
 
Registriert seit: 18.10.2005
Beiträge: 35

@Stulle
Grundätzlich benutze ich moderate Einstellungen, d.h. ca. 2000 - 3000 Quellen. Ich ziehe häufig Sachen mit vielen Quellen. Diese werden mindestens eine Woche geshared, dadurch baut sich natürlich eine große Wartschlange auf. Eine Wartschlange von vielleicht nur 500 clients habe ich nie. Ich habe höchstens so ca 100 bis 130 files im share. Deine älteren StulleMods kommen auch mit der doppelten Belastung klar. Das Programm ist sehr leistungsfähig.

[EDIT by MOD]

@Stulle

Die Service-Lösung werde ich mal nachrecherchieren

So, jetzt geht es aber ab zum Strand. Ich wünsche Dir noch einen schönen Tag.

Geändert von Myth88 (1. June 2008 um 13:08 Uhr) Grund: Doppelpost zusammengefuegt, bitte EDIT-Button benutzen!
tango2002a ist offline   Mit Zitat antworten
Alt 1. June 2008, 16:41   #51
Advanced Member
 
Benutzerbild von fafner
 
Registriert seit: 15.01.2004
Ort: Nünädachzgnullzwei
Beiträge: 205

Also ich hab hier auf besagtem P4 kein Problem mit 300 Verbindungen. Der Code ist i.O.
fafner ist offline   Mit Zitat antworten
Alt 3. June 2008, 08:36   #52
Advanced Member
 
Benutzerbild von fafner
 
Registriert seit: 15.01.2004
Ort: Nünädachzgnullzwei
Beiträge: 205

Zitat:
Vorab System:
"Stulle Rechner" PIII 800 ca. 700 MB SD-RAM
billiger Netgear Router

XP SP2, Antivir, alte Zone Alarm Pro Version

6000er Leitung

Nachdem ich den StulleMule 6.0 in ein frisches Verzeichnis installiert hatte, war ich sehr gespannt auf die nächste Session.
Der Mod geht wirklich super ab. Leider war der Spasss bereits nach 20-30 Minuten vorbei, da der Rechner einfror. Nach 1-2 Minuten ging es zwar weiter der UL/DL war jedoch bei 0. Das Spiel wiederholte sich regelmässig. Nachdem ich alle Möglichkeiten (Routerverbindungen von 400 auf 200, Verbindungseinstellungen beim Stulle gesenkt, Festplattenzugriffe erhöht - einzeln und in Kombination)ausgeschöpft hatte, dachte ich zunächst an einen Hardwarefehler, da meine Ausstattung nicht die Neueste ist.
Wirklich alle Möglichkeiten? Was ist mit Antivir & Zone Alarm? Auf alten Rechnern können solche Sachen den Muli schnell abwürgen.
fafner ist offline   Mit Zitat antworten
Alt 3. June 2008, 21:14   #53
Junior Member
 
Registriert seit: 18.10.2005
Beiträge: 35

@fafner

Ich benutze Antivir und Zone Alarm Pro bereits seit mehreren Jahren. Bisher lief alles rund. Die Diskussion über Zone Alarm auf diesen Board ist mir natürlich nicht entgangen. Aber meine alte Version läuft bisher mit der 5.1 Version des Stullemule perfekt.

Um das System möglichst stabil zu halten, arbeitet der StulleMule auf seiner eigenen Datenplatte. Allerdings läuft er in einem 100 GB TrueCrypt-Käfig, was die Geschwindigkeit etwas einschränkt. Ich habe damit jahrelange gute Erfahrungen gemacht. Erst kürzlich habe ich einen neuen Container erstellt, da der Datendurchsatz durch eine neue Programmierung bei TC verbessert wurde.

Ich werde Antivir und ZoneAlarm in diesem Zusammenhang mal näher testen. Vielleicht gibt es mit der neuen Stulle-Version irgenwelche Probleme.

Vielen Dank für den Hinweis.
tango2002a ist offline   Mit Zitat antworten
Alt 4. June 2008, 16:54   #54
Board Methusalem
 
Benutzerbild von Januar1956
 
Registriert seit: 08.06.2003
Beiträge: 2.096

@ tango2002a

Ich hatte auch schonmal sowas in der Richtung. Bei mir war es der Prozzi, der heißgelaufen ist...vielleicht mal da ein Auge draufwerfen.

Januar

Geändert von Januar1956 (4. June 2008 um 16:58 Uhr)
Januar1956 ist offline   Mit Zitat antworten
Alt 6. June 2008, 08:25   #55
Junior Member
 
Benutzerbild von Diabolo111
 
Registriert seit: 24.10.2006
Ort: Hell
Beiträge: 60

Zitat:
Zitat von tango2002a Beitrag anzeigen
Vorab System:
"Stulle Rechner" PIII 800 ca. 700 MB SD-RAM
billiger Netgear Router
mal Verbindungs-Limits prüfen, manche Router können schon über 250 probleme bekommen.

Zitat:
Zitat von tango2002a Beitrag anzeigen
Um das System möglichst stabil zu halten, arbeitet der StulleMule auf seiner eigenen Datenplatte. Allerdings läuft er in einem 100 GB TrueCrypt-Käfig, was die Geschwindigkeit etwas einschränkt. Ich habe damit jahrelange gute Erfahrungen gemacht. Erst kürzlich habe ich einen neuen Container erstellt, da der Datendurchsatz durch eine neue Programmierung bei TC verbessert wurde.
Daß Du beim TC einbußen hast, ist Dir klar. Evtl. solltest Du mal das eMule-Config und das -Temp-VZ von der Viren-Prüfung ausschließen, da dort ständig Änderungen erfolgen und somit der Viren-Scanner, unnötigerweise, tätig wird, da sich dort, normalerweise, eh keine Viren einschleichen können.

Hab nen P4 3.0 HT mit 4 GB RAM PC3200 und bei mir läuft der StulleMule 6.0 sehr stabil und einwandfrei. Was mir allderdings auffällt, ist, daß sich der RAM-Verbrauch fast verdoppelt hat.

Könnte auch sein, daß Dein Problem daran liegt. Bei mir sind, dank genügend RAM, praktisch keine Unterschiede festzustellen.

Bisher hatte ich beim StulleMule 4.5 bei gleicher Anzahl Share-Dateien (~500) immer so um 80 MB RAM-Verbrauch, nach 3-5 Tagen stieg das dann mal auf ~130 MB an.

Im Mom läuft mein Rechner grad mal 23 Std. und ich hab 230 MB RAM-Verbrauch.

Noch ne Frage @Stulle: Mir fehlen im "Datei-Detail-Dialog" die "Anzahl Defekter Dateiteile". Wurde das absichtlich weggelassen oder einfach vergessen ? Fand das schon nützlich.

Gruß Dia
__________________
„Ich denke, dass es einen Weltmarkt für vielleicht fünf Computer gibt.“ Thomas Watson, IBM-Vorsitzender, 1943

Geändert von Diabolo111 (6. June 2008 um 08:29 Uhr)
Diabolo111 ist offline   Mit Zitat antworten
Alt 6. June 2008, 08:53   #56
MODder
 
Benutzerbild von Stulle
 
Registriert seit: 08.04.2004
Beiträge: 7.035


euhm, kannst du mir mal nen screenshot machen was du meinst? also wo sollte es sein und wo fehlt es (macht zwei ). ich bin mir eigentlich keiner änderung bewusst in dem punkt...
Stulle ist offline   Mit Zitat antworten
Alt 6. June 2008, 09:24   #57
Junior Member
 
Benutzerbild von Diabolo111
 
Registriert seit: 24.10.2006
Ort: Hell
Beiträge: 60

Zitat:
Zitat von Stulle Beitrag anzeigen
euhm, kannst du mir mal nen screenshot machen was du meinst? also wo sollte es sein und wo fehlt es (macht zwei ). ich bin mir eigentlich keiner änderung bewusst in dem punkt...
Sorry , war mein Fehler, hab nochmal nachgesehen und es ist wirklich alles da, außer WC, daß ja komplett entfernt wurde. Meinte eigentlich "Wiederhergestellt: x Teile" und das ist da. Hatte da was falsches im Kopf . Iss also erledigt

Gruß Dia
__________________
„Ich denke, dass es einen Weltmarkt für vielleicht fünf Computer gibt.“ Thomas Watson, IBM-Vorsitzender, 1943
Diabolo111 ist offline   Mit Zitat antworten
Alt 6. June 2008, 12:49   #58
MODder
 
Benutzerbild von Stulle
 
Registriert seit: 08.04.2004
Beiträge: 7.035


löl okay.
__________________
Here comes the Kaiser Von Shizer! Oufweidersehen. with Hanzel und Gretyl

Ja, ich bin Misanthrop!
Stulle ist offline   Mit Zitat antworten
Alt 7. June 2008, 16:15   #59
Junior Member
 
Registriert seit: 18.10.2005
Beiträge: 35

Hallo Leute,

erst einmal vielen Dank für die vielen Anregungen.

Durch das Testen und Ausprobieren sind ein paar Tage vergangen. Leider ist es mir nicht gelungen die neue Stulle-Version stabil zum Laufen zu bewegen. Änderungen an den Routereinstellungen, Verbindungen, der Kompression, Ausstellen von Antivir etc. haben nicht die gewünschten Ergebnisse gebracht.
Ältere Versionen laufen stabil, weil ich in den erweiterten Funktionen die maximalen Verbindungen verringert und das Verbindungslimit für den Router auf max. 400 gesetzt habe. Selbst bei 4000 Quellen und einem vollen Share wird das Limit von 400 nicht erreicht. Gebe ich weniger Verbindungen an, dann gibt es bei Erreichen des Limits nur Probleme (kurzfristiges Einfrieren). Der Router läuft auch unter dieser Belastung stabil. Der StulleMule kann unter diesen Bedingungen mindestens 5 Tage fehlerfrei durchlaufen.
Übrigens fafner, Du hattest Recht. Nachdem ich ein Backup aufgespielt habe, hatte ich die Eintragung der neuen Ports in Zone Alarm vergessen. Nun wird alles flotter durchgeleitet.

Die neue StulleMule-Version ist sehr schnell. Bei meinen Testversuchen ist mir aber aufgefallen, dass diese Version ca 2 KB/s mehr Overhead (zumindest bei mir) produziert als ältere Versionen. Das hat mich ein wenig gewundert.

So, erst einmal habe ich die Nase voll vom Testen. Ich bin froh, dass derStulleMod in älteren Versionen gut auf dem Gurkenrechner läuft und file-sharing viel Spaß macht. Im übrigen werde ich nach günstigen, leisen und energiesparenden Lösungen Ausschau halten.

Was viel wichtiger ist:

Wochenende / klasse Wetter / EM

Grüße
tango2002a ist offline   Mit Zitat antworten
Alt 6. August 2008, 14:15   #60
Junior Member
 
Benutzerbild von Diabolo111
 
Registriert seit: 24.10.2006
Ort: Hell
Beiträge: 60

Da aufgrund von eMule_v0.49b wohl bald eine neue Version ansteht, hier noch ein paar Sachen, die mir bei v6.0, bzw. auch schon früher, aufgefallen sind:

1. kein Häkchen bei "FU-Platz aufbauen" in der Warteschleife - normal fällt das nicht auf, weil sofort in UP - entdeckt bei niedriger ID. Man sieht es nur durch das Häkchen vorne im ICON

2. erweiterte A4AF flags, das funzt bei mir bereits seit Version 4.x nicht richtig
- bei beiden ein Häkchen im DL-Fenster bei Rechtsklick -> Quellen-Kontrolle -> erweiterte A4AF flags -> Behalte Clients als A4AF
- Kein Häkchen im DL-Fenster bei Rechtsklick -> Quellen-Kontrolle -> erweiterte A4AF flags -> Behalte Clients als Quellen
- es ist also praktisch nicht möglich "Behalte Clients als Quellen" auszuwählen, bzw. wird es nicht angezeigt
- oder soll das so sein ? wenn ja, erschließt sich mir der Grund nicht ...

3. Bad Clients werden seit Version 6.0 nicht mehr entbannt. Selbst wenn ein solcher User > 3 GB gibt, erscheint er weiterhin ROT und erhält nur eine max. Bewertung von 1000
- entbannen nur noch manuell möglich
- benutze ScoreReduce - kein Sofort-Bann

4. Außerdem fällt mir manchmal auf, wenn ein Client mit SEHR HOHEM BR (~0,98 ) lädt, daß die restlichen, dann nicht nach 1 Chunk aus dem UP entfernt werden
- kommt bei mir manchmal vor, daß ein Client mit ~500 B ca. 12-13 MB lädt und andere, die normal abnehmen können, in dieser Zeit über 100 MB oder noch mehr laden und niemand wird mehr aus dem UP entfernt.
- Dadurch bekommen die, die in der Warteschleife stehen, keine Chance mehr in den UP zu kommen. Dauert teilweise über 1-2 Std., bis sich das wieder normalisiert
- kann das auch an dem entdeckten Bug in v0,49a liegen ?!?

5. Leecher-Abwehr: die Titanesel-MoDs haben nun den Standard-Namen -> "h**p://www.titanmule.to"

Gruß Dia
__________________
„Ich denke, dass es einen Weltmarkt für vielleicht fünf Computer gibt.“ Thomas Watson, IBM-Vorsitzender, 1943
Diabolo111 ist offline   Mit Zitat antworten
Antwort

Lesezeichen

Themen-Optionen

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are an


Ähnliche Themen: eMule 0.49c StulleMule v6.2 [26.04.2009]


  1. kann man die Serverliste seite einstellen?? bei eMule 0.49c Xtreme 7.2 [19.04.2009]
    Xtreme MOD - 16. June 2012 (5)
  2. eMule 0.49c ScarAngel v3.3 [03.12.2009]
    Xtreme MOD - 9. September 2010 (98)
  3. eMule 0.49c Xtreme 7.2 [19.04.2009]
    Xtreme MOD - 30. March 2010 (80)
  4. eMule 0.49c Final [23.02.2009]
    eMule Allgemein - 11. March 2010 (6)
  5. eMule 0.49c Ackronic 5.4 [25.12.2009]
    eMule MODs - Allgemein - 25. December 2009 (0)
  6. eMule 0.49c Mephisto v2.2 [06.10.2009]
    Xtreme MOD - 11. November 2009 (137)
  7. eMule v0.49c X-Ray v1.7 [18.07.2009]
    eMule MODs - Allgemein - 18. July 2009 (0)
  8. getrennt aus: eMule 0.49c MorphXT v11.3 [20.04.2009]
    Mülltonne - 22. April 2009 (1)
  9. eMule 0.49c MorphXT v11.3 [20.04.2009]
    eMule MODs - Allgemein - 22. April 2009 (62)
  10. eMule 0.49c Beta 2 [02/11/2009]
    eMule Allgemein - 12. February 2009 (1)
  11. eMule v0.47c StulleMule v4.5 [14.02.2007]
    eMule MODs - Allgemein - 2. June 2007 (608)
  12. eMule 0.45b StulleMule v1.1 [11.05.2005]
    eMule MODs - Allgemein - 18. October 2005 (215)


Alle Zeitangaben in WEZ +1. Es ist jetzt 07:01 Uhr.


Powered by vBulletin® Version 3.8.3 (Deutsch)
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
PAGERANK