[eMule-Web]  

Zurück   [eMule-Web] > eMule > eMule - Tools

eMule - Tools Nützliche kleine Helferlein für unser Haustier ;-)

Antwort
 
LinkBack Themen-Optionen
Alt 9. June 2004, 15:34   #1
Newbie
 
Registriert seit: 28.12.2002
Beiträge: 6
Standard: Protowall: Zugriff auf Netzlaufwerke dauert "ewig" Problem: Protowall: Zugriff auf Netzlaufwerke dauert "ewig"



Hallo Leutz!

habe komisches Phänomen:

Protowall Driver für Windows XP installiert, Protowall funzt einwandfrei, aber wenn ich auf irgendwelche Sharings im Netz zugreife dauert es ewwwwiiiigg? Sobald der Treiber ausgeschaltet ist, funzt alles wie geschmiert. Woran kann es liegen???

Wäre für jeden Tipp dankbar.




// edit: Überschrift aussagekräftig formuliert - dann klappt's auch mit der Antwort (in 90 % der Fälle) besser! Siehe Board Rules.. // cosmic girl
cobra ist offline   Mit Zitat antworten
Alt 12. June 2004, 00:19   #2
Newbie
 
Registriert seit: 28.12.2002
Beiträge: 6

eigenartig, dass keiner von Euch das Problem bis jetzt erkannt hat, ich habe das OS auch schon neu aufgesetzt, keine Besserung???

Die Protowall Profis könnten mir doch einen Tipp geben, oder nicht?

cobra ist offline   Mit Zitat antworten
Alt 22. June 2004, 17:09   #3
Newbie
 
Registriert seit: 22.06.2004
Beiträge: 1
Standard: Protowall: Zugriff auf Netzlaufwerke dauert "ewig" Protowall: Zugriff auf Netzlaufwerke dauert "ewig" Details

maybe it's your firewall ?

Problem
You are using Sygate Personal Firewall and you can't get a good transfer of data with Protowall's network driver in-place.

Symptoms
An extremely slow connection, e.g 1KB a second.

Solution
Disable Driver Level Protection in Sygate's options menu.

Tools > Options > Security
And uncheck the 'Enable Driver Level Protection' box.

Comment
Sygate says in it's help file that the Driver Level Protection is a permissions driver feature, so disabling it shouldn't cause any unnecessary security risk.

sebastien ist offline   Mit Zitat antworten
Alt 29. June 2004, 17:53   #4
Newbie
 
Registriert seit: 28.12.2002
Beiträge: 6
Standard: Protowall: Zugriff auf Netzlaufwerke dauert "ewig" Lösung: Protowall: Zugriff auf Netzlaufwerke dauert "ewig"

@sebastien

thx for your tip, but i don´t have install any firewalls. It´s nacked XP installation. Maybe another Tips?
cobra ist offline   Mit Zitat antworten
Alt 7. July 2004, 06:33   #5
Newbie
 
Registriert seit: 28.12.2002
Beiträge: 6
Standard: Protowall: Zugriff auf Netzlaufwerke dauert "ewig" Protowall: Zugriff auf Netzlaufwerke dauert "ewig" [gelöst]

habe gerade die 2.0beta installiert, ist leider immer noch das selbe Problem, alles was ich aus dem Netz entpacke (z.B. test.rar 1MB dauert ca. eine Minute zum entpacken????) oder kopierte, installiere, geht einfach furtchtbar langsam, evtl. jemand hat jemand doch einen Tipp für mich.
cobra ist offline   Mit Zitat antworten
Alt 7. July 2004, 09:12   #6
Junior Member
 
Registriert seit: 20.01.2003
Beiträge: 91

ich hatte bislang immer einen einzelplatzrechner, deshalb bin ich damit (noch) nicht vertraut. setze hier in meiner neuen unterkunft aber gerade ein kleines heimnetz mit zwo rechnern auf, wobei ich noch arg mit dem xp home meiner freundin kämpfe... wenn das alles mal läuft, kann ich von auch meinen erfahrungen berichten. wie nennen sich netzlaufwerke eigentlich auf englisch?

seh euch,
kingkaramel
__________________

kingkaramel ist offline   Mit Zitat antworten
Alt 7. July 2004, 09:16   #7
The Machine =)
 
Benutzerbild von Pathfinder
 
Registriert seit: 19.08.2003
Beiträge: 4.023


Zitat:
Zitat von kingkaramel
wie nennen sich netzlaufwerke eigentlich auf englisch?
Network Drives
__________________
filepony.de
Pathfinder ist offline   Mit Zitat antworten
Alt 7. July 2004, 16:42   #8
V.I.P.
 
Registriert seit: 07.12.2002
Beiträge: 3.033

Also ich hab schon ein paar mal Anlauf genommen, was zu diesem Thread zu schreiben, hab es immer wieder verworfen, weil meine Erfahrungen nur indirekter Natur sind und eventuell überhaupt nicht auf das Problem übertragbar sind. Ich schreibe jetzt doch mal was.

Ich benutze Linux, da läuft Protowall natürlich nicht, außerdem hat Overnet keinen solchen Mechanismus wie ipfilter.dat&Co. Die Entwickler meinen, sowas wäre Aufgabe einer Firewall. Vielleicht haben sie recht. Auf jeden Fall habe ich mir eine ähnliche Lösung erarbeitet, in dem ich eine ipfilter.dat genommen und mittels eines Onlinekonverters in ein für iptables kompatibles Format konvertiert habe. Iptables gehört zur Firewallimplementation von Linux, ist also überall dabei.

Ich habe hier also eine Lösung laufen, die genau das gleiche macht wie Protowall (gleiche Daten durch ipfilter.dat oder vergleichbare IP-Listen, gleiche Wirkung), aber komplett anderes implementiert ist (Linux halt). Interessanterweise habe ich genau die gleichen Probleme. Wir haben hier ein kleines Heimnetzwerk, 100MBit, wenn ich von meinem Rechner Daten herzu- oder hinwegkopiere, erreiche ich Durchsatzraten unter 1MB/s (es müßten locker 5-6MB/s sein, theoretisch max. über 10MB/s), aber bei voller Prozessorauslastung.

Interessanterweise normalisiert sich die Lage sofort, wenn ich die ganzen ipfilter-Regeln aus der Firewall herausnehme, die CPU-Last sinkt, die Transferrate steigt auf normale Werte.

Ich glaube, das ist völlig normal. Wenn bei mir iptables und bei euch Protowall installiert ist und man über die gleiche Netzwerkkarte ins Internet und ins LAN geht, dann muß die Wall JEDES Paket überprüfen. Zu jedem Paket kommen eine Menge Regeln in Frage, die überprüft werden müssen. Vermutlich ist deshalb so ein Bremseffekt zu beobachten.

Die Frage ist nur, ob man daran was ändern kann, vielleicht durch geschickte Programmierung der jeweiligen Firewalllösung (wobei ich glaube, das die speziell bei mir mit Linux schon recht gut optimiert sind, Protowall kann ich natürlich nicht beurteilen). Eventuell kann man auch durch geschickte Wahl der Regeln eine Verbesserung erreichen, so etwa in der Art, das generell Traffic, der an bestimmte Clients geht (die anderen LAN-Clients) direkt durchgelassen wird. Aber da müßte jemand anderes was dazu sagen, das weiß ich nicht.
__________________
info
Usul ist offline   Mit Zitat antworten
Alt 7. July 2004, 17:38   #9
Newbie
 
Registriert seit: 28.12.2002
Beiträge: 6

Hi Usul,

danke für deine ausführliche Meinung/Feststellung, mich wundert nur eins, wenn ich ProtoWall nicht aktiviert habe (Sprich die Applikation nicht gestartet ist) aber der Dienst an der Netzwerkkarte aktiv ist, ist dieses Phänomen trotzdem zu beobachten obwohl keine ipfilter.dat geladen wurde, sondern nur der Netzwerdienst, deaktiviere ich diesen Dienst flutcht alles wie gewohnt weiter, leider ohne ProtoWall, sprich irgendwie funzt der ProtoWall-Dienst nicht sauber (nicht die Applikation). Hoffe, dass evtl. hier eine Änderung stattfindet, sonst kann ich mir nur so helfen, dass ich eine zweite Netzwerkkarte einbaue, eine für LAN und die andere mit ProtoWall-Dienst für LAN/WAN. So sollte es doch gehen, oder?
cobra ist offline   Mit Zitat antworten
Alt 7. July 2004, 17:58   #10
It's cosmic ...
 
Benutzerbild von cosmic girl
 
Registriert seit: 14.01.2003
Beiträge: 3.326


Wenn der Dienst, von dem du sprichst, die gleiche Funktion übernimmt, wie ProtoWall, so spielt es doch keine Rolle, ob das Programm läuft oder nicht.

Die Überprüfung der Pakete, die dieser Dienst dann vornimmt, bremst eben den gesamten Netzwerk Traffic so runter.

Wäre nun interessant zu wissen, ob andere auch dieses Problem haben.

Vielleicht kann kingkaramel uns dazu näheres berichten, wenn er nach seiner Online-Abstinenz demnächst alles nachgeholt hat, was es an neuen Infos auf bluetack.co.uk zu verdauen gibt.


Habe im ProtoWall thread dazu auch was geschrieben, nachdem Usul das Thema von hier auch dort mal crosslinked hat.
http://www.emule-web.de/board/viewto...=109176#109176
__________________
cosmic girl ist offline   Mit Zitat antworten
Alt 7. July 2004, 22:00   #11
Junior Member
 
Registriert seit: 20.01.2003
Beiträge: 91

@pathfinder
*stirnpatsch* habe "net drives" gesucht, ist aber ne software

@alle wegen thema
ich bin noch nicht dazu gekommen, mein heimnetz zu checken, aber habe eine kurze info zu einer teilfrage:

wenn der protowall-driver ein häkchen hat, dann ist er auch automatisch aktiv. die software könnt ihr euch wie ein gui oder besser eine steuereinheit vorstellen. übrigens benutzt ihr nicht zufällig realtek-chipsatz-nics? die brechen vom speed her gewaltig ein, wenn protowall läuft. fiel mir gerade ein, weil alle user mit diesen nics die einbußen durch pws funktionsweise ebenfalls mit installiertem dienst haben, selbst wenn die exe nicht läuft. eine mögliche lösung habe ich im pw-thread geschildert!

einen schönen abend noch!
kingkaramel
__________________

kingkaramel ist offline   Mit Zitat antworten
Alt 8. July 2004, 06:39   #12
Newbie
 
Registriert seit: 28.12.2002
Beiträge: 6

Hin kingkaramel,

danke für den Tipp was die Netzwerkkarte angeht, ich verwende die "Realtek RTL8139-Familie-PCI-Fast Ethernet-NIC", gibt es einen Patch dafür? Oder soll ich lieber eine andre NIC verwenden?
cobra ist offline   Mit Zitat antworten
Alt 8. July 2004, 09:55   #13
Junior Member
 
Registriert seit: 20.01.2003
Beiträge: 91

@cobra
steht alles im haupthread zu protowall, nur ein paar mausclicks entfernt lies mal der eröffnungspost, gleich die ersten zeilen, und folge den links.

pax vobiscum,
kingkaramel

edit:
inzwischen habe ich einiges an feedback, und bei den meisten hat's funktioniert. ich ergänze dazu jetzt noch eine info im hauptthread!
__________________

kingkaramel ist offline   Mit Zitat antworten
Antwort

Lesezeichen

Themen-Optionen

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are an


Ähnliche Themen: Protowall: Zugriff auf Netzlaufwerke dauert "ewig"


  1. Basiert die Android-App "gTunes" auf filesharing??
    Filesharing - 8. December 2010 (2)
  2. Bluescreen "BAD POOL CALLER" beim "eseln"
    Hard- und Software Allgemein - 30. June 2008 (8)
  3. T-Sinus 1054 auf der "eMule - Überholspur"
    DSL Router - 24. February 2007 (69)
  4. Was Bedeutet "another Server Lowid", Warte schon 4 Tage auf die letzten 9 MB
    eMule MODs - Allgemein - 7. October 2006 (8)
  5. "skins"-Ordner auf dem Desktop
    Xtreme MOD - 7. August 2006 (8)
  6. Erfahrungen mit emule auf Linux "amule"
    eDonkey - Overnet - Kdrive - 7. November 2005 (5)
  7. Kann "Portforwarding" und/oder "Portmapping" nicht finden
    DSL Router - 14. August 2005 (7)
  8. "achtung!! wichtig!!.txt" War plötzlich auf meinem
    Mülltonne - 4. March 2004 (2)
  9. "blockieren" und "verstecken" von parts?
    eMule MODs - Allgemein - 28. July 2003 (13)
  10. Hilfe!! Komme nicht mehr auf "Home"=http://192.168
    DSL Router - 22. February 2003 (4)


Alle Zeitangaben in WEZ +1. Es ist jetzt 01:46 Uhr.


Powered by vBulletin® Version 3.8.3 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
PAGERANK